GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

"Validation Failed" when people download our app, HELP PLEASE

thegabbathegabba Posts: 142Member, PRO
edited 5:39PM in Tech Support
Hi guys we already post this thread into another section but we still don't know what to do.

Apple published yesterday the update 1.1 of our "Escape from LaVille" and there's a BIG problem:
when you open it, the game crashes with an alert saying: "Validation failed. This game's publishing license is not valid". We never had this issue before the game was on the App Store.
We sent yesterday an email to Apple via iTunes connect to inform them about this issue but still no answer. We know this may take several days so we thought to publish a new update but we want to be sure to do all correctly this time.
Please help us :)

Thank you very much

Comments

  • thegabbathegabba Posts: 142Member, PRO
    bump :S
  • thegabbathegabba Posts: 142Member, PRO
    Trying to find out the difference between the previous workin' version(1.0) and the new one on the app store(1.1) we discovered that, inside the 1.1 app, the 'Publishing_license' file was empty.
    This is probably the cause of the problem. We tried several time to re-publish it but we get the same issue. We NEED to send to Apple the update because the game is unplayable and we're getting a tons of bad reviews. So please GS Team help us :)
    Thank you very much
  • LBGLBG Posts: 277Member
    Hey thegabba. I am having the same problem after multiple tries. Where can I view the "publishing_lisence" file so I can check mine?

    Thanks

    Wayne
  • thegabbathegabba Posts: 142Member, PRO
    right-click on your app-build and select:"show package contents". Inside you'll find a file named: publishing_license and it will probably be empty. I think this is the issue but i can't figure out how to solve it..
  • LBGLBG Posts: 277Member
    Are you using the latest build of GS? (0.9.5)
  • thegabbathegabba Posts: 142Member, PRO
    no, I'm using the same version(0.9.3) i used for the working app. I can't use 0.9.5 because of the 'NoSound bug' :S
  • LBGLBG Posts: 277Member
    I'm in the same boat. I don't like to upgrade during development unless I have people to test for me. Unfortunately it's just me working on my app at the moment so I couldn't take the time to test and wanted to stick with 0.9.3 till the cycle was finished. It seems like GS don't support older versions of their software when you publish to their servers. We are both therefore stuck as we wont upgrade to buggy software but they don't support older versions of GS. I am going to get my app as finished as possible then back it up and try 0.9.5. If it works, great. If not then I'll have to wait. Who knows how long though.
  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    Guys it should be no surprise that GS doesn't allow you to publish with older versions. They have not allowed this since 0.9.0

    And FYI if you modify the .app file GS sends Back it will be corrupted and Apple will not accept it.

    It's not my fault I never learned to take responsibility for anything. ;)

  • LBGLBG Posts: 277Member
    @ tnrdrmer

    I am new to development with GS so for me it is a surprise. I started using 0.9.3 and this is my first GS app. I have worked in games for 7 years and have never been forced to have to patch or upgrade any software whether it be DEV tools or game engines (I have used the cryengine and Unreal). So yes, I am surprised.

    FYI I am not looking to modify any files. I am trying to get an adhoc build to work on my phone and exploring all avenues as to why it will not.

    LBG
  • thegabbathegabba Posts: 142Member, PRO
    Hi tenrdrmer,
    actually we published our 1.0 app on the App Store with 0.9.3 when 0.9.4 was already released.
    I just tried to publish with the upgrade 0.9.5 and it seems the 'publishing_license' file is ok.
    The problem now is that 0.9.5 is buggy(no sound)so we can't udate our app and the users' bad reviews are growing on the app store..
    btw we don't want to modify the publishing_license file at all, we just opened it to find out the issue. If you know a way to solve the 'nosound bug' please let us know :)
    Thank you
This discussion has been closed.