GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

"This game's publishing license is not valid"

LBGLBG Posts: 277Member
edited 8:37PM in Tech Support
I have uploaded the app and had the binary back which installed fine on my phone. All good so far. When I try to play the app though I get "This game's publishing license is not valid". Has anyone else had this error or know what I need to do? I have an ad hoc provisioning profile and have dropped that into itunes too. Do I have to install that profile on my phone too?

Thanks for any help

Wayne

Comments

  • osucowboy18osucowboy18 Posts: 1,307Member
    I had the same problem yesterday. What I did was this. I uninstalled the app from my device, I deleted the app from iTunes, and I republished the app with GameSalad. Make sure your provisioning profiles and certificates are up to date as well. Good luck :)

    - Alex
    _________________________________________________________________________________

    Target Practice Template
    Custom Soundtracks and Sound Effects For Sale
    Vertical/Horizontal Level Select Template
    Mac Mini For SALE!!!
  • LBGLBG Posts: 277Member
    just trying again
  • LBGLBG Posts: 277Member
    still not working! I have no idea what I am doing wrong. should I only have the ad hoc provisioning profile installed on my device?
  • GrubGamesGrubGames Posts: 77Member
    Are you trying to download an AdHoc on your phone? or are you trying to test with GS Viewer?
  • LBGLBG Posts: 277Member
    I have managed to download the AdHoc after publishing using the AdHoc provisioning profile. I have the Profile on my device and in iTunes too.

    The app syncs to my device but when I try to launch the app I get: "This game's publishing license is not valid".
  • GrubGamesGrubGames Posts: 77Member
    Try this. With your device plugged in to your computer open up Xcode. Go to the organizer. You should see your phone or device on the left side. Under it should be applications. Click it. On the bottom of this screen there is an add button. Browse and find your packaged app from GS, upload (unzipped) it. It should take about a minute. If it shows up on this screen then it should be functional on your device.

    If this doesn't work you are going to have to go back to the dev center and make sure your provisioning profiles, certificates, and appID match up.
  • firemaplegamesfiremaplegames Posts: 3,206Member
    Any app that successfully installs on your device will NOT be able to upload to the App Store. Only apps signed with a development profile or an adhoc profile will install.

    Which means they were not signed with a Distibution profile.

    Go back to the the Provisioning Portal and make sure you correctly create and download a Distribution profile for app.

    When you publish through GS, make sure you select the Distribution profile as well when you sign your app.
  • osucowboy18osucowboy18 Posts: 1,307Member
    LBG said:
    still not working! I have no idea what I am doing wrong. should I only have the ad hoc provisioning profile installed on my device?

    Sorry you still haven't gotten it to work. For some reason it worked for me after republishing with GameSalad. If I think of anything else to try, I'll let you know.

    - Alex
  • LBGLBG Posts: 277Member
    GrubGames said:
    Try this. With your device plugged in to your computer open up Xcode. Go to the organizer. You should see your phone or device on the left side. Under it should be applications. Click it. On the bottom of this screen there is an add button. Browse and find your packaged app from GS, upload (unzipped) it. It should take about a minute. If it shows up on this screen then it should be functional on your device.

    If this doesn't work you are going to have to go back to the dev center and make sure your provisioning profiles, certificates, and appID match up.

    I tried doing this with xcode but I get the same error. I have also checked my certificates and the ID's are the same for all the ones I am using (development and ad hoc). Could it be a problem with the binary I got back from the upload?
  • LBGLBG Posts: 277Member
    I have been through all of tshirtbooths tutorials and I still can't get it to work. Please help as I am so close to finishing an app I have been working on for months and am getting a little worried.

    Many thanks,

    LBG
  • LBGLBG Posts: 277Member
    Hi everyone,

    Sorry to post this here. I have put it in the publishing section but the re seems to be no traffic there and I am desperate.

    I have managed to publish and install my app to my phone to test but when I try to launch it I get the above error. Has anyone else seen this?

    I have been through the tutorials concerning provisioning profiles and certificates and am farily certain I have it right.

    Any help would be greaty appreciated,

    Many thanks

    Wayne
  • LBGLBG Posts: 277Member
    I am using version 0.9.3 in fear of something going wrong with the code in my app. Could this be a problem? Do I also need the latest xcode version?
  • LBGLBG Posts: 277Member
    Any chefs out there please? I'm getting a little desperate.

    Thanks
  • LBGLBG Posts: 277Member
    Or Sous Chefs?..... Sorry to bump
  • LBGLBG Posts: 277Member
    anyone please?

    bump
  • LBGLBG Posts: 277Member
    anyone? Please?
  • thegabbathegabba Posts: 142Member, PRO
    Hi LBG we discover a thing that may be the cause of the problem:
    http://gamesalad.com/forums/topic.php?id=26727
    but we still don't know how to solve the issue...
  • LBGLBG Posts: 277Member
    Hi,

    I have posted in two other forums and had a little help but nothing that is fixing the problem.

    I have published and succesfully installed my app but when I launch it I get the above error message. I have re assigned new app IDs, re published and still the same thing. I have seen elsewhere that these problems have occured before as a result of the publishing process on GS side.

    I really need to resolve this asap as I am just about ready to launch this app and need to test it in adhoc this week.

    Many Thanks,

    Wayne
  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    I've merged all of your threads into one. All of the categories show on the main page. There is no need for one each section of the forum.

    It appears people have tried to help you with this so if its still not working you need to try contacting GameSalad.

    I would recommend Making sure your certificates are not expired and then delete download and reinstall them.

    It's not my fault I never learned to take responsibility for anything. ;)

  • LBGLBG Posts: 277Member
    Thanks tendremer but I have checked all of this and they are not expired. I have even deleted profiles and re-made them with a different app ID just to rule out any overwriting issues.

    After having read another thread it seems that I need to upgrade to 0.9.5 (currently still on 0.9.3 after reading horror stories before updating to 0.9.4). I just want to know now if I update to latest and it breaks something will it be perma broken or will any future patches / updates fix these issues?

    I have emailed GS and am waiting a reply.

    Many Thanks

    Wayne
  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    tenrdrmer said:
    Hmm it looks like you may have found why your publishing is not working properly. And yes if it breaks it you will likely not be able to use that project file in the next update.

    Thats why you need to have backups of all your stuff so you have a copy that has not been opened with 0.9.5

    And no I do not know of a bugs list.

    However the only one I can think of right off the top of my head is other wises don't always work. people have been having to separate the rules out get their games working

    It's not my fault I never learned to take responsibility for anything. ;)

This discussion has been closed.