GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Support for sound formats dropped?

invisibleZEBRAinvisibleZEBRA Posts: 6Member
edited November -1 in Tech Support
Sorry if this topic sort of exists already- the new website is a bit messed up and just redirects me back to the forum home whenever I try and open a topic.

I usually use .mp3 and .wav files and import them straight into gamesalad. After updating to version 0.9.5 (this might effect earlier versions because I hadn’t update in a while) only .OGG and .CAF sounds worked. After emailing gamesalad support they said that they hadn’t dropped support.

I got them to work only by renaming them, for example “Sound.mp3” becomes “Sound.caf” but they are a bit dodgy as not all of them work. Is there a solution? Would it be solved by reinstalling gamesalad?? >:o

Comments

  • quantumsheepquantumsheep Posts: 8,188Member
    That is really weird.

    I know others have been having sound problems but I've not experienced it myself yet.

    I usually receive (from my music guys) .mp3 files for both sound effects and music.

    I then edit these to be mono in Audacity, and export from there to .wav files.

    Then I re-open these freshly made .wav files as the conversion usually adds quite a bit of empty space to the sound file.

    Again, export as .wav

    Drag the new .wav files into the creator tool under audio. It asks you if you want to import as music/sound and I choose the appropriate one.

    I've never had an issue doing it this way - is there anything different in the way you import your music/sounds to what I've done?

    QS

    Dr. Sam Beckett never returned home...
    Twitter: https://twitter.com/Quantum_Sheep
    Web: http://www.quantum-sheep.com

  • invisibleZEBRAinvisibleZEBRA Posts: 6Member
    Nothing different really to what I've done in the past. Before the update it used to work fine. I'll go ahead and reinstall the creator when I get time and see if that fixes anything.

    As I said I do have a temporary fix (just sticking a .ogg or a .caf on the end of the filename- works for some sounds) so until then I can continue with some gamesalading.

    Thanks for the quick response- I wonder if anyone has fixed this- have to wait and see what reinstalling does.
  • invisibleZEBRAinvisibleZEBRA Posts: 6Member
  • quantumsheepquantumsheep Posts: 8,188Member
    Oh.

    Mine worked fine from 9.3 - 9.4 - 9.5

    I really must have a charmed version or something... :O

    Good luck!

    QS :D

    Dr. Sam Beckett never returned home...
    Twitter: https://twitter.com/Quantum_Sheep
    Web: http://www.quantum-sheep.com

  • SlickZeroSlickZero Houston, TexasPosts: 2,870Member, Sous Chef
    I don't know how, but I've always been under the impression that GS accepts various types of sound files, but in the end, it either converts them to .ogg for sounds, and .m4a for music. I always convert them in Audacity to either one of these before importing into GS, and I have never had an audio issue yet.

    I have no friends. I'm a loser that makes video games all day. Will you be my friend?

  • invisibleZEBRAinvisibleZEBRA Posts: 6Member
    Ok I have solved my problem, I think. For the whole time before I had been just dragging wavs and mp3s straight in and letting gamesalad convert the files to .ogg or .m4a which worked fine.

    I'm not sure exactly how or why, but after the update it seems like gamesalad no longer converts the files (for me anyway), but still imports them. This would explain why they are there, but don't work/ have any sound.

    So I just started using Audacity to convert them instead, like SlickZero (and everyone else probably) which is even better because now I can edit them too.

    No idea why I never did it that way before. The 'problem' still exists but isn't a problem any more. Its possible that they don't convert sounds for you any more, or maybe its just my weird version- although I asked gamesalad support and they just said that they *hadn't* dropped support for any sound formats.

    :P
This discussion has been closed.