GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Ton of new bugs with Gamesalad's behaviors, layers, music, etc.

TheMenOfHonorTheMenOfHonor Posts: 147Member
edited November -1 in Tech Support
Afternoon, everyone.

Ever since I updated to 0.9.6 I've had a massive amount of game-breaking bugs appearing during development and testing. I'd really appreciate someone helping me with some of these:

- In certain scenes, behaviors don't work. Animations don't appear, spawners don't work, and movement behaviors simply stop. I put the exact same actors in other scenes and they work as directed with no problems. I've restarted gamesalad and my Mac many times without success in remedying these issues.
- When I send an image to the back, it doesn't go to the back layer. When I send a certain actor to the front, it stays in the back.
- When testing on the iPhone or iPod Touch, music stops after moving out of the menu. Any tests on the Mac or viewer the music continues as normal. Only when it is published does it not start.

To sum it all up . . . it's gamebreaking, all of it. I'm rather desperate for help, because if these can't be fixed, I can't continue development. I would really appreciate some insight into why the actors are now simply ignoring behaviors. I've worked with gamesalad plenty before, and I've never seen ANY of these problems before . . . :/

Comments

  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    For the layers to update you just have to press the preview button. Just switching the layers without hitting preview you wont see the change
  • TheMenOfHonorTheMenOfHonor Posts: 147Member
    Just tried it, the one actor still remains in the back. I deleted the actor and reset it, but it went straight to the back again . . .
  • StormyStudioStormyStudio United KingdomPosts: 3,987Member
    Are you using the layers window to organise their order or right clicking?

    Use the layers window if It helps.

    Also it sounds like your actors work in new scenes, could you recreate your scene in a new one easily enough? Keep checking it works as you build it as it might be a rogue actor causing the problems.
  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    TheMenOfHonor said:
    - When I send an image to the back, it doesn't go to the back layer. When I send a certain actor to the front, it stays in the back.

    Send to back and send to front only work within the same layer. They do not change they layer the actor is in. The only way to do that is to re-organize them in the layers window.

    It's not my fault I never learned to take responsibility for anything. ;)

  • TheMenOfHonorTheMenOfHonor Posts: 147Member
    Thanks guys, I got the layers thing working smoothly. I forgot that I used the window to organize certain layers. ^_^

    I've haven't had much luck working with the scene problem, though I've got it "fixed" for now. I deleted every actor from the scene where behaviors no longer worked, and I put just a few animating actors in. Even those failed, so I deleted the now-empty scene. This scene had been working perfectly before today. Nothing I can remember had been added.

    I created an entirely new scene and placed every single actor back in, and it's currently working fine. I'm not quite sure what on earth caused the problems in some scenes (the problems appeared to have arose without cause), but at least for now, behaviors have returned to normal. I still wish to avoid this same situation arising in the future, when the project is further along in development, so I'll keep looking into it . . .

    Thanks to everyone who's offered advice so far!
  • TheMenOfHonorTheMenOfHonor Posts: 147Member
    Update. Now every scene, regardless of when I made of or when I make it, the actor's behaviors do not work. Nothing, not so much as an animation works. I'm not sure why gamesalad is doing this, but it can't continue. Anyone have any ideas? :/

    It's very odd, but I found another thing. If I put the other actors down before another, they work . . . even if I put the actor in later. But vice versa, and the whole thing implodes. Just . . . odd, really, but at least I can continue this way.
  • Fodder76Fodder76 Posts: 154Member
    I'm glad to see someone else having some of the same issues I've had. I just made an AdHoc build of my game and first I noticed the sound wasn't playing... and now a lot of my actors aren't spawning properly. I knew these issues were a result of the new version update as I haven't touched these aspects of my game in months.

    Does anyone have a fix for my actors not spawning anymore? I'd hate to 'fix' it since nothing is wrong with my code, but I don't want to wait for another update either.

    Thanks very much for any help.
  • TheMenOfHonorTheMenOfHonor Posts: 147Member
    I haven't actually been able to fix the actors, but I did find something that works. Although there was nothing actually wrong with one of the actors (all it did was animate, change alpha, and follow the mouse) while it was on screen it negated other actor's behaviors. The only thing I could do was make an entirely new actor. Finding the offending actor may be tough if you have a lot of them.

    I submitted a bug report, and got an email sent asking for my project file. I sent it, but no reply just yet. Though it's to be expected--some of the bugs were pretty bad. :/ I'd imagine a new update is coming very soon.
  • thebitmasterthebitmaster Posts: 75PRO
    I'm seeing something similar, where some actors on the screen, all from the same prototype, are sometimes not running parts of their behaviors. I submitted a bug, and noted the problem here:

    http://gamesalad.com/forums/topic.php?id=28572

    I may try re-creating one of my scenes from scratch to see if the problem goes away. Thanks for bringing this up and keep us abreast of your progress working around.
  • thebitmasterthebitmaster Posts: 75PRO
    On additional thing. I was having a similar problem where moving an actor between layers changed the behavior of a bunch of other actors, and also where adding a new actor completely messed up a scene, and deleting it fixed everything.

    The culprit was a problem in my code. I've found two instances where this happened.

    1) I used random(100) instead of random(1,100) in a calculation. This caused several later behaviors to not always fire. Once I fixed it, the problem went away

    2) I got pissed because something I should have been able to copy-and-paste wouldn't work. I could copy the code into a text editor, and copy it back, but just trying to copy from one place in GameSalad to another didn't work. I used to text editor as an intermediary and copied the text anyway. The problem is that the pasted text had game variables names in it, but because it was pasted from an outside source, GameSalad wasn't recognizing it as the proper variable.

    To clarify, if you create an expression by choosing Game.myVariable from the chooser box, it creates a variable object that work. If, however, you type exactly the same text "Game.myVariable" into the box, it will *not* work. There is an additional, somewhat hidden linking going on inside somewhere. I believe you can see the blue box around the correct variable, but not around the incorrectly pasted one. At any rate, once I found this and re-created it by painstakingly re-building the entire expression from scratch by choosing each variable from the box, it fixed the problem.

    These kind of bugs aren't flagged in any way by GameSalad, but they cause you're actors behaviors to not work correctly. You can usually narrow down where in the actor the problem is by seeing which behaviors don't fire when an actor is present. The bug is usually right before those behaviors.
This discussion has been closed.