GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

XCode tells me I need to update to latest ios - but I have!

tallguy1000tallguy1000 Posts: 12Member
edited January 2012 in Tech Support
After downloading the latest version of the GS viewer, updating my provisioning profile and app id (several times), and basically doing everything I can, I click RUN it tells me that i need to upgrade to the latest version of ios. I have the latest version. so why does it say this? It is very frustrating, does anybody have a clue as to what i must do?

Comments

  • fzeedfzeed Posts: 247Member
    Mine did that to. It turns out i was using xCode 4.1 instead of 4.2
  • tallguy1000tallguy1000 Posts: 12Member
    Oh wow! I'll check if I need to update. Big thanks!!
  • tallguy1000tallguy1000 Posts: 12Member
    No, I'm on 4.2. Any other ideas?
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,914Member
    What type of device and what iOS is the device running? GS no longer support anything below version 4
  • tallguy1000tallguy1000 Posts: 12Member
    ipad ios version 5.0.1. This is the latest yes?
  • tallguy1000tallguy1000 Posts: 12Member
    Mmmm.. A Google check has made me think I need to upgrade my Mac OS from Snow Leopard to Lion. Is anybody running XCode 4.2 on Snow Leopard successfully? I suppose I should upgrade anyway.
  • Rob2Rob2 Posts: 2,402Member
    I have just installed and used the viewer on my iPad from Xcode 4.2 on SL and it built quite happily to a universal 3.2 deployment target. My iPad is 5.0.1.
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,914Member
    edited January 2012
    Just make sure you set the target deployment to ios 5.0 in xcode. Yeah I tried installing on an ipod touch 2nd gen with 4.2 but it won't run any apps. The viewer installs fine but won't run the apps. Not sure about adhoc but viewer no luck and I never have problems as my ipad works great as well as my Kindle, although the Android viewer will gltich up from time to time.




    Gleeson Group Media
    UNoffical Gamesalad Guide
    FREE and easy to use. Contains all well done video tutorials for Gamesalad.
  • Rob2Rob2 Posts: 2,402Member
    You need to post the exact messages you are getting.
  • Rob2Rob2 Posts: 2,402Member
    edited January 2012
    @David G Deployment Target is the minimum iOS you want an app to run on NOT the installed iOS on a specific device.
  • tallguy1000tallguy1000 Posts: 12Member
    The message I receive is :
    "No provisioned IOS devices are available with a compatible IOS version. Connect an IOS device with a recent enough version of IOS to run your application or choose an IOS simulator as the destination."
    I've update GS Viewer loads of times and never had a problem. All App ID's , provisioning profiles and certificates are there. My iPad has IOS 5.01 installed and I've re-installed XCode just in case. I'm Adhoc as I'm not ready for distribution yet. I've tried every provisioning profile, deleted all expired ones and created new ones to try. I've messed with changing deployment targets, My provisioning profiles have ages left on them and my Apple Developer Account is fully paid up. Arrrrggghhhh!! What's going on? I'm on Snow Leopard but by all accounts this shouldn't make any difference? Somebody please help!
  • Rob2Rob2 Posts: 2,402Member
    edited January 2012
    Plug in ipad
    Run Xcode
    Open Xcode Organizer
    Select ipad in library on left
    Is light green ?

    edit: make sure devices is selected at top of organizer window.
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,914Member
    Just on other thought there are two versions of Xcode one for lion and one for snow, do you have the right one?
  • Rob2Rob2 Posts: 2,402Member
    If you are still having problems http://developer.apple.com/library/mac/#documentation/ToolsLanguages/Conceptual/Xcode4UserGuide/Devices/Devices.html
    make sure you click on the blue bullet points.
  • bschenabschena Posts: 1Member
    Gah. Same problem here. I just upgraded GSC (0.9.90), then upgraded the viewer (version 1.0?) on 2 IOS5 devices (which work). I then retargeted to IOS4.2 and loaded it onto an iPod Touch 2nd Gen (build 8C148) that USED to work with GS, but now doesn't. The light is "green" in the Xcode Organizer, and the GSV app shows as loaded (version 1.0). When I try to preview on the Touch, I get "connecting, compressing, connected, loading" but then I get the popup "Gamesalad Viewer Update Required" and "Please download and install the latest version of GameSalad Viewer." dialog.

    What gives? This USED to work before I "upgraded".
  • tallguy1000tallguy1000 Posts: 12Member
    I fixed the problem. It seems that for some unknown reason, upgrading xCode deleted my device from the "Devices" area in Xcode. I simply added my iphone 4s and voila - it works! So simple, but hey - why did it do that? So irritating!!
  • tallguy1000tallguy1000 Posts: 12Member
    I meant ipad!
This discussion has been closed.