GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

about auto rotation.

TheFrogeekTheFrogeek Posts: 97Member
edited July 2012 in Tech Support
Hello every one!
I don't understand how to disable screen rotation when I rotate my device. I want my screen to stay in landscape left position.
I'have tried to do something in "Game=> Devices=> Screen" and in "Scene=> Attributes=> Autorotate" but it failed, the screen rotate when I rotate my device.

Is it a bug or an improper handling of me?

Thank you.

Best Answer

Answers

  • UtopianGamesUtopianGames Posts: 5,686Member
    edited July 2012
    Have you tried a build for your device as i don't think the screen rotation settings work with the previewer and device.

    Darren.
  • gyroscopegyroscope I am here.Posts: 6,577Member, Sous Chef, PRO

    Hi @kloo13

    Darren @UtopianGames info is correct; also:

    make sure you've set your Landscape Left in EVERY scene and,

    as you are choosing Landscape Left in this case, Apple requires you to choose Landscape Right (in every scene) too.

    Hope that helps.

    ""You are in a maze of twisty passages, all alike." - Zork        temp domain http://spidergriffin.wix.com/alphaghostapps

  • TheFrogeekTheFrogeek Posts: 97Member
    Thank you for your answers UtopianGames and gyroscope.
    My problem, with screen rotation, happens when I test my game on my iPad by using the viewer.
    Maybe It comes from the GS viewer?
    I chose Landscape Left in every scenes and in every Devices options. But (if I understand what you say gyroscope) I have to choose Landscape Right in every scene too?!
    Is that way to correct my problem or just a clause from Apple?
  • J_PANJ_PAN Posts: 140Member
    Go under scene attributes for each scene and go to autorotate. one of the rotations should be checked. uncheck all of the checked ones and it shouldn't autorotate anymore
  • TheFrogeekTheFrogeek Posts: 97Member
    Thank you for your help every one, but when I launch my game on my iPad with the viewer, the screen still rotate when I rotate my device 8-} . I've unchecked all the booleans attribute in autorotate, in each scene but it doesn't work (and I checked all my scene twice ).
    In: game => device => screen => I turned Device Orientation to landscape left and to unknown but it still the same.

    Any other idea?
  • andnowmediaandnowmedia Posts: 1Member
    Like kloo13 when I test my game on my ipad 2 the screen tilts to vertical when I turn the ipad, even though I checked only landscape left and right on all the individual pages. Also, using the latest (10.0) version of Gamesalad, when I select "publish" none of the selections appear that are reflected in this TShirtBooth youtube video ... instead the only option is "upload" ... but I do not want to share my test game with the entire gamesalad community. How can I fix this??
  • CluvCluv Posts: 229Member
    The Tshirtbooth video is for setting up adhocs through the apple Dev account. It isn't for the publishing through Gamesalad. When you publish for iPad through game salad, it will open up a web screen where you have the option to set up publishing for iPad, iPhone, android, etc. You are not required to open source or share it with everyone.

    Tldr; gamesalad publishing and an adhoc are two different things.
  • TheFrogeekTheFrogeek Posts: 97Member
    Thank you cluv I'll check it later and I'll give you my feedback!
    Thank you à lot for all your suggestions and your help I realy apreciate.
  • carlblanchetcarlblanchet Posts: 755Member
    Pretty sure this is a bug with the viewer. It will auto rotate even if the game says not to do so.
  • HymloeHymloe Posts: 1,651Member
    I really thought that Game Salad would address these problems with 0.10.0, seeing these bugs were mostly all happening in Game Salad 0.9.94.

    The viewer MUST respect the orientation settings the user sets, so we can test properly. Please fix ASAP. Stupid bug to appear in two separate version. Let down.

    Also, with the game I published recently, on iPad 2, if you rotate the game while it's loading, the splash disappears, and the screen just goes black for the remainder of the load time. Some people have reported to me that they thought it was broken, or crashed at this time.

    It's really embarrassing and frustrating when my games are let down by things that are beyond my control. ESPECIALLY when they continue from one release of Game Salad to the next.

    Here's hoping we see these sorts of bugs getting more effectively ironed out (or not appearing at all!) in the future builds.
  • TheFrogeekTheFrogeek Posts: 97Member
    This is the right way to do!!
    Thank you gamesalad community!!
  • ctceismcctceismc Posts: 36PRO
    If you lock the orientation of an iPhone/iPod touch/iPad the GS viewer app will be locked in the portrait position and will not rotate. If you need to test in landscape mode go into settings-general-accessibilty-AssitiveTouch-ON. This will place a small dot on the screen. Once the GS viewer app is opened in the locked portrait mode you can touch the AssistiveTouch dot and follow the icons to rotate to landscape. The GS viewer app will now be locked in landscape mode until you restart it or press the home button. This works well for testing accelerometer based games without having to do an adhoc build in both portrait and landscape orientations. The GS viewer will not autorotate if you follow these instructions.
  • TheFrogeekTheFrogeek Posts: 97Member
    Yes! and in "general seting" of my device I can use lateral switch to lock ration.
    But the real problem is that the GS viewer is bugged.

    If you want to play your game on your device without change your seting, for now, I think, that the only way is to exporte as ad hoc. But the process is very long compared to use the GS viewer.
    It´s a pity.
  • HymloeHymloe Posts: 1,651Member
    @kloo13 Yes, it's a real pity they can't just fix it to work properly, like it used to many versions ago, and like it plainly should.

    @ctceismc Thank you heaps for those instructions! I've not been able to figure out how to lock the iOS Viewer to landscape on my iPod Touch 4. Thank you! I'll give that a try.

    @GameSalad Please fix this in the next version. It's so annoying that it doesn't work properly. Thanks.

This discussion has been closed.