GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Problem with Save As

tothemax98tothemax98 Posts: 19Member
edited August 2012 in Tech Support
I cannot save as without losing images and sounds in my app. I have recently upgraded to mountain lion and suspect this may be the cause as I have never had trouble with save as in gamesalad before. I tried reinstalling gamesalad and rebooting but problem persist. I am ready to publish and planned to upgrade to gamesalad pro today but need a solution to this problem as the app is corrupting on save as. Any solutions?

Comments

  • tothemax98tothemax98 Posts: 19Member
    Sorry about multiple post was not sure if they would ever be read as they were older. Tried reinstalling after deletion and problem persist.
  • jigglybeanjigglybean Posts: 1,584Member
    I have this problem using the Windows version. The only solution I have found(for Windows) is to create new folders and rename the versions as you. Then delete the old folders. Pain but its the only way

    Like Balls? Then click here! We've 100 coming soon

  • tothemax98tothemax98 Posts: 19Member
    Thanks I will try this as soon as I can find my folders. Apple just changed the way folders are handled with mountain lion. So I now need to research why I can not see my root directory where I created folders for my app assets. I have to say macs are way overrated on simplicity, that is unless simplicity = relearning how to use your computer with every incremental os update.
  • tothemax98tothemax98 Posts: 19Member
    OK after setting finder to again show my root mac HD I found my asset folders. I tried creating new folders and deleting old folders. I still can run my old gamesalad app fine but as soon as I save as images and sound files are lost.
  • tothemax98tothemax98 Posts: 19Member
    So for others having this problem I found a workaround. Just right click on the good gamesalad file and select "show package contents" and then manually copy all images, screenshots and sounds from their respective folders to the new save respective empty folders.
This discussion has been closed.