GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Application Loader Problem - Says icon dimensions are 0 x 0, need to be 57 x 57

RavenbellRavenbell Posts: 10Member
edited August 2012 in Tech Support
Using the Application Loader to submit my game to Apple, I get an error message that says:

"Icon dimensions (0 x 0) don't meet the size requirements. The icon file must be 57 x 57, in .png format."

I have tried just about everything I can think of, and gamesalad won't let me submit the icon as anything but a 512 x 512 jpeg. I've searched the forums and found a few similar problems, but the solutions there didn't work for me. Any detailed help or suggestions? It's been one tiring afternoon of trying, so is this just a problem with the gamesalad uploading service that should be fixed soon?

Over the past year, I've been a quiet lurker here trying to develop my game and all. You've all been very helpful to me, and many thanks in advance to whoever tackles my question.

Comments

  • lycettebroslycettebros Posts: 1,598Member, PRO
    Hmm that is odd. Not a problem with GS I think.
    But first the latest GS will require 1024x1024 icons and not 512x512 (also better to use PNG than JPG)...icon info comes from iTunesconnect and the appstore etc. will scale icons down to necessary sizes.
    The 57x57 is weird....have you rebooted your machine after installing new GS?
    have you installed the latest Xcode SDK and rebooted after that....
    there is also a newer version of the application loader out there so make sure you have that latest version too.
  • RavenbellRavenbell Posts: 10Member
    I haven't installed the latest GS yet, because I am still running Snow Leopard. Do you think that could be causing the problem? I would use a PNG if I could, but the icon viewer in the GS Publish menu won't let me select a PNG. I'm pretty sure my Xcode and Application Loader are up to date.
  • lycettebroslycettebros Posts: 1,598Member, PRO
    No that should not be the problem.
    I could be wrong but I thought the only format for icons in GS was PNG, all my icons are PNG and work fine.
    Maybe try the icon size at 1024 if it lets you?
  • RavenbellRavenbell Posts: 10Member
    I will try that. It only makes sense that they would be PNG, so I have no idea why it doesn't let me use them.
  • lycettebroslycettebros Posts: 1,598Member, PRO
    Very strange. I am 100% positive that you need to use PNGs.
    Double check the files and re-export them from imaging software in PNG format (make sure they are 24bit with no transparency).
    The old GS may not let you upload 1024x1024 so have 512x512 ready as well.
  • RavenbellRavenbell Posts: 10Member
    Nope, no luck. It will only accept 512 x 512. But I had a thought: During the publishing process, does Gamesalad upload and cut down the Icon by a certain fixed percentile? In other words after 1024 x 1024 icons became the norm in version 10.0, is the server cutting my image down to the wrong percentage, therefore messing up my app? In such case, upgrading to Lion and updating GS might work?

    I'm so brain tired right now, I don't even know if this makes sense.
  • RavenbellRavenbell Posts: 10Member
    ^Sorry, I posted my last post before I read yours. Actually, I re-exported a non-transparent PNG 24 and it accepted it. We'll see how this goes. The issue was before I had kept checking Yes transparency in the PNG box.
  • RavenbellRavenbell Posts: 10Member
    Still not working. Same message. At least it lets me have a PNG now, but it won't let me use a 1024 x 1024. **sigh** Any other ideas?
  • lycettebroslycettebros Posts: 1,598Member, PRO
    Yeah 512 is the max the old GS will support for the icon.
    If you are tired then give up now and return refreshed. Someone else may post something more in depth about the error.
  • lycettebroslycettebros Posts: 1,598Member, PRO
    I cannot think of what the error is referring to from the loader but an error with the icon information within the app package.
    I am off for my dinner - hopefully someone else can suggest something.
  • RavenbellRavenbell Posts: 10Member
    Yeah I'm planning to give it a rest. It's just hard when I am so, so close. Anyhow, thanks for the help, man.
  • RavenbellRavenbell Posts: 10Member
    Still having this issue. I created another App version in the publisher, because I thought maybe the original got corrupt, but this did not resolve the issue. Any ideas?
  • RavenbellRavenbell Posts: 10Member
    Just resolved the issue. Apparently when I last updated all my Apple Software, it hadn't updated Application Loader. Application Loader 2.4.1 is giving out the error, but 2.5.1 works. Just submitted my game =) .
  • lycettebroslycettebros Posts: 1,598Member, PRO
    edited August 2012
    Good to hear @Ravenbell...looks like a sleep helped!
    Actually you did not sleep!
  • EpicEpic Posts: 89Member
    Oh thank you for finding this out I spent all day today trying to get it to work ended up getting angry and walking away
This discussion has been closed.