GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

"A provisioning profile with matching developer identity is required to publish iPhone games."

micksolomicksolo Posts: 264Member
edited August 2012 in Tech Support
I get this message when trying to sign my app.

Gamesalad 10.0
Lion 10.7.4
Xcode 4.2.1

I deleted and re-created all my certificates and provisioning files but still keep getting the same message.

Any help appreciated,

Thanks

Mick

Comments

  • micksolomicksolo Posts: 264Member
    thanks man, I have done all that and still get the same error.
  • micksolomicksolo Posts: 264Member
    as an update to this, I upgraded xcode to 4.4.1 (or whatever the latest version is).

    deleted and recreated all of my certificates and provisioning - all of them showed as valid in keychain and xcode organizer

    still had the same issue in GS 10.0

    Downgraded to GS 0.9.94 and I could publish a project fine.

    So GS - it's something at your end, please investigate and fix quickly as this is a pretty important that I can publish my projects.
  • jonmulcahyjonmulcahy Posts: 10,383Member, Sous Chef
    I don't think it's on gs's end or everyone would have problems. In v0.10 you must manually enter the bundle it. If it does not match your profile exactly it won't show up.

    You must also ignore the number prefix to the bundle: I.e. SD23SGR.com.bundle.id you only enter com.bundle.id
  • micksolomicksolo Posts: 264Member
    ok i finally worked it out. it's not a (bad) bug at GS' end.

    for some reason it didn't like when I updated my project. when i created a new project with the provisioning and app id, it worked and I could publish. I don't know why I didn't try that before, guess I just assumed that the updating project would work properly.

    It's very weird...hopefully GS can iron that out so others won't have the same issues.
  • micksolomicksolo Posts: 264Member
    ok...so this issue isn't resolved. My test app using my usual provisioning and app ID was working, but when I used my actual game project it was still giving me the "cannot find provisioning file" error.

    After much jigging around I think I have worked out what the problem was. My game title contained a non alpha-numeric letter, a question mark. When I removed that, it seems to work just fine.

    Just to recap, this is not the bundle identifier, but the actual display name, the name you see on the iphone menu underneath your logo.
  • adriangomezadriangomez Posts: 78Member, PRO
    micksolo I having the same problem. I have published before on this same machine, so I know it is set up correctly. But I can't publish with the latest version. Where did you change the name? In the binary? Or just on the publishing page?
  • micksolomicksolo Posts: 264Member
    hey, so GS confirmed this is indeed a bug.

    Where you change the name is in the publishing page, in "Display Name". It's weird its happening as the display name shouldn't affect the bundle identifier but for whatever reason if you use a non alpha numeric character for your display name (like a question mark) it will not find your provisioning file.

    4 days worth of frigging around to find this ridiculous bug.

    image
  • Krehol GamesKrehol Games Posts: 42Member
    Micksolo,

    Did you delete the entire project from your portfolio and then change the name? Ive tried updating my name to remove special characters, regenerated the app, and Im still getting the same above error message at app signing. no provisioning profile is found.
This discussion has been closed.