GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Incorrect object positon

Raf124Raf124 Posts: 2Member
Hi,

I have recently installed games salad creator 0.10 and i have strange problem related to objects positioning.
When I place simple actor (with default settings) in the center of scene and go to scene preview, it is seen in left down corner of preview area.
Editor view : http://imageshack.us/a/img267/2450/editora.png
scene preview: http://imageshack.us/a/img829/1466/scenepreview.png

Do You have any idea what is happening ?

BTW I also have issues with dragging and dropping actors to scene. I have to do it twice, and only after second time actor is actually visible in the scene... but I end up with 2 instances, where first one is completely not usable.

Comments

  • SocksSocks London, UK.Posts: 12,822Member
    edited December 2012
    Do you have a rule on your actor that tells it to position itself in the lower left hand corner ?

    Why is the actor an instance rather than a prototype ?

    Can we see the rules (if there are any) for the prototype.
  • Raf124Raf124 Posts: 2Member
    There are no rules created at all. As I've written, there are only default settings for new project.
    Actor placed on the screen is an instance because that is how game salad treats object dragged and dropped from library. As far as i understand prototype is in library and it is "class", object droped to the scene is an instance of this class.
  • patrykadaspatrykadas Posts: 24Member
    The same happens in my case in Windows7.
  • MagiKaLMagiKaL Posts: 1Member
    This is happening to me as well, I need to ensure that the position shown in the edition window is the same in the preview! Anybody knows why is this happening? I'm also using the Windows version on 2 different pc's and it doesn't work in any of 'em!
  • -Timo--Timo- Posts: 2,313Member
    this bug is only on windows... when there is a decimal after the position, size or something else it won't work like you want it. make sure you delete the decimals in the actor then it should work fine :)
    also the color doesn't work very good. you only can use (only) green blue and red... so not mixed.
    good luck!
This discussion has been closed.