GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

GS Android Viewer not stable on Android 4.2.1 and 4.2.2.

My Nexus 7 (Android 4.2.2) with GS Android Viewer 0.10.1 will not properly display PNGs or crash when loading projects over 2MB. I have created fresh projects with a single PNG and still get just a scrambled static representation on the Actor. I have updated both the viewer and GS to 0.10.1. I've also cleared the GS Viewer Recent, and Android Caches. Still getting scrambled static.

I have a Nexus 7 running Android 4.1.1 with GS Android Viewer 0.10.1 that works fine.

It seems that the GS Android Viewer is not stable on Android 4.2.1 and 4.2.2.

Any suggestions, help, or updates would be greatly appreciated.

Comments

  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    So based on a recent post from you. Is it just the viewer that is not working or have you tried actually publishing an APK and loading it for testing?

    It's not my fault I never learned to take responsibility for anything. ;)

  • particleProjectparticleProject Posts: 5Member
    edited February 2013
    Yes, it's just the viewer in Android that's not working. I have not published an APK. I'm not a PRO so can't publish Android. I'm just exploring GS for school use.
  • I'm currently upgrading to pro (My school ID is being verified). I'll try the publishing route, but that seems laborious for the types of testing I'm doing.
  • ImpactBlueStudiosImpactBlueStudios Posts: 53Member
    Also getting this issue. Viewer works perfectly on Android but not 4.2 and up. Graphics are just a fuzzy white box and the game crashes immediately.

    Is there an updated version of the viewer where this is fixed?
  • ImpactBlueStudiosImpactBlueStudios Posts: 53Member
    These issues seem to be fixed in Android GS Viewer 0.10.2
  • particleProjectparticleProject Posts: 5Member
    I updated to PRO, went through the apk packaging, & loaded it on the N7. It shows the Icon in my downloads folder, but fails to install (X app not installed). APKs from Adobe Air install just fine using the same process.
  • RubiWorksRubiWorks Posts: 130Member
    I have the same problem. Not works in Nexus 7 :/
  • HymloeHymloe Posts: 1,651Member
    I'm trying to get it working on my Wildfire S (OS 2.3.3). It just crashes.

    Going to try a system update to 2.3.5 which is as high as this device can go.

    Viewer works fine on my HTC Desire HD, which is OS 2.3.5.

    Did any of you guys sort out your Android Viewer crash issues? If so, how? :)
  • HymloeHymloe Posts: 1,651Member
    edited August 2013
    I updated my Wildfire S to OS 2.3.5 (Software number 2.26.841.4).

    The Android Viewer still crashes when I try to run my project.

    Would love some advice or help here @BlackCloakGS.

    Is it a known issue that the Android Viewer doesn't work on some Android devices? What do you know about this issue? Is it solve-able?
  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
    edited August 2013
    @Hymloe will take a look at the viewers tomorrow. Also I don't have a Wildfire S in the office but i will see if we have any HTC devices running 2.3.3-.5 and take a look.
  • HymloeHymloe Posts: 1,651Member
    Great.

    I just tried making an unsigned APK through the publishing system (of my 2.5MB test app), and when I tried to install it, it says "Application not installed" (with a green tick next to it!?).

    Application doesn't seem to have installed in my applications list.

    I have Unknown Sources ticked (and have had it ticked the whole time).


  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
    @Hymloe what version of the viewers are you trying to use and what version of creator are you using?
  • HymloeHymloe Posts: 1,651Member
    edited August 2013
    I tried with Creator and Viewer version "Nightly Build 0052", and then Creator and Viewer version "Nightly Build 0075".


    I've just installed LogViewer (LogCat), and I'm looking through the messages in there.

    I can see some that look relevant:

    17:04:21.057 ResourceType
    No package identifier when getting value for resource number 0x00000000

    17:04:31.227 ADB-related
    Could not mkdir 'WildfireS-Test-00217.gameproj'

    17:04:31.227 ADB-related
    Could not mkdir 'WildfireS-Test-00217.gameproj/actors'

    17:04:31.347 ADB-related
    Could not mkdir 'WildfireS-Test-00217.gameproj/behaviours'

    17:04:31.347 ADB-related
    Could not mkdir 'WildfireS-Test-00217.gameproj/images'

    17:04:31.367 ADB-related
    Could not mkdir 'WildfireS-Test-00217.gameproj/scenes'

    17:04:31.497 ADB-related Could not mkdir 'WildfireS-Test-00217.gameproj/screenshots'

    17:04:31.497 ADB-related Could not mkdir 'WildfireS-Test-00217.gameproj/sounds'

    17:04:31.497 ADB-related Could not mkdir 'WildfireS-Test-00217.gameproj/tables'

    17:04:32.608 InputDispatcher
    channel '40b9ed30 com.gamesalad.viewer/com. gamesalad.viewer.GSViewerActivity (server)' ~ Consumer closed input channel or an error occurred. events =0x8

    17:04:32.608 InputDispatcher
    channel '40b9ed30 com.gamesalad.viewer/com. gamesalad.viewer.GSViewerActivity (server)' ~ Channel is unrecoverably broken and will be disposed!

    17:04:32.608 Zygote
    Process 1742 terminated by signal (4)

    2013-08-09 17:04:32.738 I 323/wpa_supplicant:
    Rx Data Filter Add [0] command

    2013-08-09 17:04:32.738 D 120/dalvikvm:
    GC_FOR_MALLOC freed 1020K, 34% free 8648K/13063K, external 900K/1212K, paused 141ms

    2013-08-09 17:04:32.738 E 120/WifiService:
    Multicaster binderDied

    2013-08-09 17:04:32.738 I 120/WindowManager:
    WIN DEATH: Window{40b9ed30 com.gamesalad.viewer/com.gamesalad.viewer.GSViewerActivity paused=false}

    2013-08-09 17:04:32.748 I 323/wpa_supplicant:
    Rx Data Filter Add [3] command

    2013-08-09 17:04:32.748 I 120/ActivityManager:
    Process com.gamesalad.viewer (pid 1742) has died.

    2013-08-09 17:04:32.758 D 120/issue:
    WindowManager framework defect: detect view leak, fix it manually



    Perhaps I have illegal characters or other syntax illegalities in my filename for my project, or something?


    I've sent you a personal message with a link to the crashlogs.

    I also included a "trimmed" version which I think isolates a single attempt to run a build through the GS Viewer.
  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
    @Hymloe thank you for the additional information i will look at this tomorrow.
  • HymloeHymloe Posts: 1,651Member
    To the lay man, it looks like the process is failing after it can't actually unzip the game onto the device. Any ideas what's going on there?

    Do I have some sort of "ADB-related" problem?
  • HymloeHymloe Posts: 1,651Member
    Is there some process you need to do with the device plugged into the computer, to set up the ADB process for the device or something?

    It's been ages since I actually set up my HTC Desire HD, so now that I've got this Wildfire S, I just installed the viewer APK, and expected it to work, pretty much.

    I've got "Unsigned Sources" ticked and "USB Debugging" (although I don't actually see why that's needed, seeing the game is sent over wirelessly...?)

    Have I missed a step with setting up my device, maybe?
  • HymloeHymloe Posts: 1,651Member
    I followed this great tutorial on signing APKs, and made a signed one, which then installed fine, but it still doesn't run.

    If I tap the icon for my app on the home screen, it flicks to black for less than a second, then returns back to the home screen.


  • HymloeHymloe Posts: 1,651Member
    edited August 2013
    I'm now finding that my builds aren't working on the HTC Desire HD, now that I've upgraded to Nightly Build 0075. Strange!
  • HymloeHymloe Posts: 1,651Member
    Went back to 0052 Creator and Viewer on my HTC Desire HD, and it works again on that.

  • HymloeHymloe Posts: 1,651Member
    Tried 0052 again on Wildfire S, and it just crashes as soon as the game tries to start up in the Viewer. The game loads over from the Mac to the Viewer, and as soon as it does, it crashes.

  • HymloeHymloe Posts: 1,651Member
    I've tried everything I can think of for now. So hopefully you can figure out what's going on, @BlackCloakGS. All the best. Let me know how it goes.
  • HymloeHymloe Posts: 1,651Member
    Ahh! Interesting.

    I've just run 0.10.1 and sent it to my Wildfire S running the Android GSViewer 0.10.1, and it works! So something has gone wrong between 0.10.1 and Nightly Build 0052.

    Great to see Game Salad viewer working, even if it is a rather old version. :) At least it gives me hope, and lets me know that it's something wrong in the newer Game Salad versions.

  • HymloeHymloe Posts: 1,651Member
    On the Wildfire S, it simply crashes in 0.10.2 and 0.10.3, even on a test project with only one actor in it.

    Must be something to do with the introduction of LUAJIT, or something around that time...?


    When I do get the older 0.10.1 games running, the framerate is rather bad, even on a project with 2 balls bouncing around a box. The audio stutters and jerks.

    On the other hand, I can grab a few random apps on the App Store, such as Rovio's Amazing Alex and Angry Birds Rio, and another game called Sniper Shooter, and all are quite nice and smooth, with consistent audio, and very playable experiences, even on the Wildfire S.

    I hope the new attention being put on Android at Game Salad will yield a much improved engine that results in playable framerates and smoother audio, even on some older devices.
  • HymloeHymloe Posts: 1,651Member
    With Game Salad 0.10.3, I can load my test app onto my HTC Desire HD. But not the Wildfire S. It seems as though certain devices have somehow been put on a blacklist, or deprecated in some way...?

    But I'm running the same OS on both devices, so it's not that. I have 2.3.5 on both.

    Oggy's World (downloaded from the Google Play Store) runs smoothly on my Desire HD, but simply won't load on the Wildfire S. It gives the same quick flash of black, then shutdown, that I get when trying to preview my own projects.



  • HymloeHymloe Posts: 1,651Member
    What concerns me perhaps the most is that my Desire HD can't even load Android Viewer projects in the very latest nightly build 0076. So I get the feeling that the blacklist of Android devices is growing, and more and more devices are being left off the bottom.

    Would be great to hear some clarification of what's causing more and more Android devices to stop being supported by Game Salad, and how it's going to be addressed.

  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
    @Hymloe I have a HTC my Touch running 2.3.4 I am looking into the android issues now.
  • HymloeHymloe Posts: 1,651Member
    Great!

    It looks like the specifications for the My Touch 3G is similar to the Wildfire S (even a bit worse), and the My Touch 4G is very similar to the Desire HD (both 1GHz, 480x800, Adreno 205).

  • HymloeHymloe Posts: 1,651Member
    Hope you're making good progress @BlackCloakGS.

    Perhaps it's just some values in the AndroidManifest that are cutting off certain devices because of their OS versions, SDK version, or something...?
This discussion has been closed.