GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Serious IAP problems

I'm not a noob. I have an app in the store, that get's IAP's purchased every day.

However, my latest app refuses to be able to test in adhoc mode, and returns the error "Product identifier was not recognized". I've done the following:

Created a provisioning profile with a developer certificate. I've added it to xcode, and itunes.
Ensured that the prov. profiles have the same bundle ID as the app in itunes connect.
Set up my in apps and activated them in the app details on itc.
Ensured that the product id in Gamesalad matches the product id in itc exactly.
Ensured that I am signing with the ad hoc profile.

There used to be a checkbox on the Publishing page for ad hoc builds. What happened to that? Is it supposed to be gone?

Whatever though, as far as I see it, I'm doing everything right here and I need some help. It's really fucking me off.

2nd set of eyes please.
«1

Comments

  • LiquidGameworksLiquidGameworks Anchorage, AKPosts: 956Member, Sous Chef
    edited February 2013
    I don't think GameSalad has updated their system to be compatible with iOS 6.1 yet. Also, there is no adhoc checkbox. It will recognize an adhoc profile if you've used one.
  • epicstagepicstag Posts: 132PRO
    That's good to know. At least I wont keep messing with it and driving myself even closer to insanity. Any word on an ETA for 6.1?
  • ChakkuChakku Posts: 1,513Member
    epicstag said:

    That's good to know. At least I wont keep messing with it and driving myself even closer to insanity. Any word on an ETA for 6.1?

    They usually bring in all of the bugs and fix them with the next release. As we recently got the Universal Builds release, it will be a (relatively) long time before the next release.

    Although they may release a hotfix, as this sounds like a serious issue :/

    Chakku
  • epicstagepicstag Posts: 132PRO
    Chakku said:

    epicstag said:

    That's good to know. At least I wont keep messing with it and driving myself even closer to insanity. Any word on an ETA for 6.1?

    They usually bring in all of the bugs and fix them with the next release. As we recently got the Universal Builds release, it will be a (relatively) long time before the next release.

    Although they may release a hotfix, as this sounds like a serious issue :/

    Chakku
    If no builds work with the current version of IOS, this needs to be addressed quickly. It absolutely breaks my development.

  • ChakkuChakku Posts: 1,513Member
    epicstag said:

    Chakku said:

    epicstag said:

    That's good to know. At least I wont keep messing with it and driving myself even closer to insanity. Any word on an ETA for 6.1?

    They usually bring in all of the bugs and fix them with the next release. As we recently got the Universal Builds release, it will be a (relatively) long time before the next release.

    Although they may release a hotfix, as this sounds like a serious issue :/

    Chakku
    If no builds work with the current version of IOS, this needs to be addressed quickly. It absolutely breaks my development.

    Yeah, I agree with you.

    Chakku

  • epicstagepicstag Posts: 132PRO
    Does this mean that anything built will just not work with anyone who has updated their phone to 6.1 (meaning the vast majority of every single iOS user)? Or is this somehow isolated to testing or something.
  • ChakkuChakku Posts: 1,513Member
    epicstag said:

    Does this mean that anything built will just not work with anyone who has updated their phone to 6.1 (meaning the vast majority of every single iOS user)? Or is this somehow isolated to testing or something.

    Now that would require immediate attention!! :(

    Chakku

  • SnapFireStudiosSnapFireStudios Posts: 1,603Member

    Ignore females. Acquire currency.

  • epicstagepicstag Posts: 132PRO
    Thanks for the link @SnapFireStudios . I think there's more than just the few if us that are worried. I also wonder if IAP is broken now in apps that are already in the App Store, and if they need to be rebuilt and submitted.
  • Primo.TMPrimo.TM Posts: 35PRO
    Hey, my game has just been approved by Apple with no problems regarding in-app purchases. So maybe there isn't an issue with iOS 6.1..? I'm just waiting for it to go live in a couple of hours and I'll have some tests on the actual version.
  • epicstagepicstag Posts: 132PRO
    edited February 2013
    Did you build and sign the app after 6.1 was already out? At any rate, we've gotten confirmation that 6.1 isn't compatible with Gamesalad in the thread mentioned above by @snapfirestudios

    There's a lot of variables though, so hopefully your game is A.O.K.
  • Primo.TMPrimo.TM Posts: 35PRO
    Yes, I built and signed it 6 days ago, so yes, after 6.1 was out. All my In-App Purchased work fine.
  • epicstagepicstag Posts: 132PRO
    edited February 2013
    Welcome to the minority. Also a 6 day turnaround right now? I can't wait to submit. I had to wait over 2 weeks prior to Christmas.

    I wonder if we can isolate why yours are working and the rest of ours are not. Any thoughts @saladstraightshooter?
  • epicstagepicstag Posts: 132PRO
    @Primo.TM Can you put what your product ID's are for your app? I'm trying to isolate what is causing issues in 6.1, and if yours are working, I want to see if there is possibly a naming convention change on Apple's side that could be effecting things.
  • Primo.TMPrimo.TM Posts: 35PRO
    edited February 2013
    I don't know if this will be helpful, but for IDs I use "thenameofmyapp100coins" (no dots, no dashes, etc.) and I write them manually into the ID field. I don't use tables to get their names and values.
  • epicstagepicstag Posts: 132PRO
    OK, I was using the id from the cookbook, product_iapname, however, I created a test IAP with no underscore called productTest, which isn't working either, so this must not be the problem. Thanks though.
  • DoguzDoguz Posts: 500Member
    Just found this thread, I too am having problems testing my IAP in add hoc mode.

    When i click the 'buy' button on the 'Confirm your in app purchase' prompt, in [Environment:Sandbox]

    a second prompt appears saying In-App Purchase failed
    Cannot connect to iTunes Store.

    I've never done this before. Is it supposed to carry through and make the purchase?
  • Primo.TMPrimo.TM Posts: 35PRO
    Did you create a test user account in iTunes?
  • DoguzDoguz Posts: 500Member
    Do you mean itunes connect? yes if you do
  • Primo.TMPrimo.TM Posts: 35PRO
    Yes, iTunes Connect. Also make sure you have logged out from your original account in Settings - iTunes & App Stores, because this is the error I get when I forget to switch accounts.
  • DoguzDoguz Posts: 500Member
    edited February 2013
    Do i need to go into settings -> itunes & app store. And log out of my normal account adn then log in with my test account?

    Seems like too much work. Surely apple made it easier.
  • Primo.TMPrimo.TM Posts: 35PRO
    Yes, you need to do that. See my previous comment.
  • DoguzDoguz Posts: 500Member
    OK, thanks @Primo.TM Done that. although it wanted to take me thru the whole insert your credit card details in itunes etc. But I just cancelled out of that, went back to my app and then no account was logged in, so I input my test account when prompted. It's now working in test sandbox mode and I'm purchasing all sorts of stuff.
  • epicstagepicstag Posts: 132PRO
    The having to actually log out of itunes buggers a lot of people. It isn't a well documented detail on Apple's part. What iOS and device are you running @Doguz?
  • DoguzDoguz Posts: 500Member
    iPhone5 & iOS6.1.2
  • epicstagepicstag Posts: 132PRO
    Is there anyone on this thread who has a working IAP prototype build that would be willing to add my device id to your ad hoc, and send me the provisioning profile and project .app files to me, so that I can test a confirmed working build on my phone?
  • lycettebroslycettebros Posts: 1,598Member, PRO
    6.1.3 is on the way too :(

    I have an IAP app awaiting review now. Will report back on the outcome.
  • lycettebroslycettebros Posts: 1,598Member, PRO
    @epicstag
    Can confirm that my IAP app has been approved by Apple - so this means current GS is OK with 6.1.2.
  • epicstagepicstag Posts: 132PRO
    Distribution build works? Does ad hoc? @lycettebros?
  • lycettebroslycettebros Posts: 1,598Member, PRO
    @epicstag

    iPhone iOS 6.1
    IAP on Dist build works perfectly
    Adhoc worked too.
This discussion has been closed.