GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Epic bug on iOs viewer

gameviccigamevicci Posts: 294Member, PRO
Hi,
I work with GS from 3 years, it's great!
With 10.3b now I'm working on a platform game, the epic problem is that in Preview I see this:
https://dl.dropboxusercontent.com/u/3958016/a.png

while on iOS viewer.... I see this: https://dl.dropboxusercontent.com/u/3958016/b.PNG

I tried to:
1) change project name
2) change project title
3) clear iOS viewer games
4) restart Mac (with OSX 10.8.2) and iPhone4 (with 6.1.2)

thanks a lot
Federico

Comments

  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,906Member
    Do you have something on the non scrollable layer possibly?
  • jonmulcahyjonmulcahy Posts: 10,376Member, Sous Chef
    what happens when you do an adhoc build, that's really the only accurate way to test on the device.
  • MantoManto Posts: 791Member
    For me it just looks like your project platform is iphone landscape, you're testing the game on iPhone 4 and have overscan turned on.
  • ORBZORBZ Posts: 1,303Member, PRO
    Turn off overscan and they will look the same - but you will need to design for overscan on for Apple to approve it. This is because of the diff in screen size between iPhone4 and iPhone5
  • gameviccigamevicci Posts: 294Member, PRO

    Do you have something on the non scrollable layer possibly?

    No, blocks are in a scrollable layer. Moreover on the Mac preview it works fine, on the iOs viewer there are no destroyable blocks, and some new behaviors are missing (like double jump, axe throw etc)

    ORBZ said:

    Turn off overscan and they will look the same - but you will need to design for overscan on for Apple to approve it. This is because of the diff in screen size between iPhone4 and iPhone5

    I know that I posted an iphone5 preview's screenshot and an iphone4 viewer's screenshot, but the overscan is not the problem (I use iphone5 size on preview, and move only the HUD when screen.size width is 480), the problem is that I can do some changes in the game (e.g. if I change the background) , but I can see them only in the preview, not in the iOs viewer.
    It's the first time in 3 years that I see this bug

    However guys thanks a lot! I'll wait for a tech support
  • ORBZORBZ Posts: 1,303Member, PRO
    Ahh, i see your point. I didn't notice that the platforms were missing between the two pictures until just now! I have no idea what could be causing that. You're right, that is a weird bug. What happens if you make an adhoc build?
  • gameviccigamevicci Posts: 294Member, PRO
    Just tried an adhoc build...it's the same :(

    I think I will wait a support from GS...

    However ORBZ thanks for your old waypoints template :) (I used it to make Minicars Touch)
  • gameviccigamevicci Posts: 294Member, PRO
    I just tried even on nightly build 0.0.0.27 and it's the same...
  • gameviccigamevicci Posts: 294Member, PRO
    I found it!

    https://dl.dropboxusercontent.com/u/3958016/c.png

    I was using the behavior if self.Color.Alpha is 0.9 --- destroy
    Now I create a boolean in the actor and it all works fine.

    So this is the bug: now in the iOs viewer (and in adHoc builds) the alpha color probably changes before the loading of a scene, I made some experiments and it's always the same, on iphone4,5,iOS 6.1, 6.3 etc etc

    I used to use this way (if self.Color.Alpha is 0.9) to don't create new variables (and reduce memory usage), I made 3 games with this trick, but now in latest version of Mac creator it doesn't work
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,906Member
    edited June 2013
    I know I've had scenes get corrupted recently. I had to delete the original scene and rebuild it.
  • ORBZORBZ Posts: 1,303Member, PRO
    edited June 2013
    @gamevicci

    Your problem is that the value 0,9 is not valid and causes the actor to not run.

    0.9 is what you want.

    GS 10.3 became more sensitive to invalid expressions. Invalid expressions used to just evaluate to 0 and the actor would keep running. Therefor bugs were harder to notice. Since 10.3 invalid expresisons cause the actor to simply fail to execute. Making the bugs more noticable. In your case the 0,9 is an invalid expression because GS wants . not ,
  • gameviccigamevicci Posts: 294Member, PRO
    Just to make a test I tried to use 0.9 but the bug still persist.
    Moreover with both 0.9 or 0,9 it works fine on Preview and doesn't work on iOs viewer.

    The only way is to don't use self.Color.Aplha (and I used this trick many times in other games)

    However thanks for this free help!
  • ORBZORBZ Posts: 1,303Member, PRO
    edited June 2013
    How does alpha get changed?

    Are you sure you don't want less than equal to 0.9 ?

    If alpha is being interpolated (or changed in other ways) its possible that due to rounding errors that alpha is never exactly 0.9.
This discussion has been closed.