GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can't preview on iOS device anymore :(

CoolBeeCoolBee Posts: 81Member
So I made a few more additions/changes to my app today and when I came to test it either the iPhone app crashes OR Gamesalad itself crashes :( I've tried it with literally all the templates etc so it can't be just my app, I press preview on iPhone and loads the first bar then when it comes to loading game it just crashes, I've tried completely uninstalling and reinstalling a fresh both on the iPhone and the mac AND I've even tried the earlier version (10.2) on both devices and the same thing happens! Can anyone help?

I've copied the crash report into a doc file if anyone can find the solution that way
https://www.dropbox.com/s/ltu7ujdtnctnphi/crash.docx

Comments

  • RPRP Posts: 1,990Member
    What versions of OSX and Xcode are you running?
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,906Member
    Trash the GS and reinstall it.
  • CoolBeeCoolBee Posts: 81Member
    edited July 2013
    @RP , @FryingBaconStudios Trashed Gs that didn't work reinstalled 10.2 and tried 10.3 both on the mac and the Gs viewer on the phone, it's running mountain lion so its on 10.8.4 and the latest version of xcode :(

    This is one of the top lines in that crash report Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,906Member
    Okay this is a bad memory allocation error. I know GS fixed the issues on their end regarding this so look for an attribute error such as mistakenly putting a number into a Boolean or vise versa. This will now cause crashes in the new LUA JT engine.
  • CoolBeeCoolBee Posts: 81Member
    @FryingBaconStudios But it happens with all the templates not just my project, like I open up the platformer template click preview on iOS device and Gs crashes with the same error
  • RPRP Posts: 1,990Member
    edited July 2013
    That's weird. I've seen that with memory and corrupt plists. Hmmm...

    GS does not really have a whole lot in the system, other than what's under it's own wrapper.

    Well, when was the last time the computer restarted?
    What computer do you have. I'm wondering if it's a setting that has not released statically. There are ways of flushing it out. PRAM zappage

    Any ram upgrades? Third party memory? Any other apps crashing?

    Any recent software additions? Any new accessories attached to you machine?

    *wondering if it is potentially tied to the GameSalad_Viewer-Info.plist

  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee
    @CoolBee thank you for the crash report i will look into it
  • CoolBeeCoolBee Posts: 81Member
    @NP nothing new that I know of, its a 2012 retina mbp, I'll look into PRAM whatever that is? Not installed anything of late etc no ram upgrades all stock 8gig etc is there anything I should be looking at removing which the trash might not pick up?
    @BlackCloakGS hopefully you can find out more otherwise it'll be a bit of a disaster considering how far I've come with the dam app :(
  • CoolBeeCoolBee Posts: 81Member
    @BlackCloakGS , @FryingBaconStudios , @RP YES its working! I've found the culprit! it appears "Little Snitch" was suddenly blocking an inbound connection once I stopped the filter it instantly worked again! thanks for your help guys :)
  • RPRP Posts: 1,990Member
    @CoolBee

    Give this a shot. Sometimes (very rarely) certain memory settings that do not refresh can cause unexpected behavior. Now, I'm not sure this is the cause of the issue, but this will not hurt and will aid in the troubleshooting steps. In my years of Apple experience, when I have had something hinkey going on, Power Management, PRAM resets were quite effective. Give it a shot and test it out.

    http://support.apple.com/kb/HT1379

    "Shut down your Mac.
    Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    Turn on the computer.
    Press and hold the Command-Option-P-R keys before the gray screen appears.
    Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    Release the keys."
  • CoolBeeCoolBee Posts: 81Member
    @RP it has been going alittle wappy recently so I'll give this a shot thanks!
This discussion has been closed.