GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Issue with GS viewer "xcode cannot run using selected device"

Player_EPlayer_E Posts: 604Member, PRO
edited 2:43AM in Tech Support
So i've been having this issue since updating my iphone 3GS to 5.0

I have xcode version 4.2 (I believe it is current)
I have GS version 9.82 and the viewer to go along with it

After changing my bundle ID and so on I make sure to change the build in xcode on top left to
GameSalad Viewer > iOS Device (which should be my iphone while plugged in)

But i receive this error once I click Run.

"xcode cannot run using selected device"
No provisioned iOS devices are available with a compatible iOS version. Connect an iOS device with a recent enough version of iOS to run your application or choose an iOS simulator as the destination.

I check and I still have my provision profile on my device... so I really dont know what the issue is.

Any help would be awesome :)

Comments

  • JadarStudiosJadarStudios Posts: 264Member
    Is the 3GS on the provisioning profile?
  • Player_EPlayer_E Posts: 604Member, PRO
    If your asking is my device registered under the provision portal on developer.apple.com then yes
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    Player_E said:
    If your asking is my device registered under the provision portal on developer.apple.com then yes

    no hes asking if your device is added to the provisiong profile your using. you still have to add the device to the profile even though you have your device registered.
  • Player_EPlayer_E Posts: 604Member, PRO
    well, I'm not quite sure what that would be then and ill have to look into it when im off of work, so any additional clues on how to add my device to the profile would be great.

    despite my absense on the forum I have been using GS for quite some time. Back before save feature, to date myself since im not quite sure on what version that was.

    I have used the viewer before and unless "adding my device to proilfe" is something new in the last update or two I really doubt that is the issue.

    But like I said any info on how to do so would be greatly appreciated.
  • RumiRumi Posts: 343Member, PRO
    plug it in, open up xcode, select window>organizer and click your device and then use for development
  • threepeasoupthreepeasoup Posts: 33Member
    Hey Player_E

    I am having the same problem right now. My ipad 2 and Iphone 3gs just updated to 5.0 and is running into this problem:

    Xcode cannot run using the selected device.
    The version of iOS on “iphone” doesn't match any of the versions of iOS supported for development with this installation of the iOS SDK.
    The version of iOS on “ipad” doesn't match any of the versions of iOS supported for development with this installation of the iOS SDK.

    I am stuck! please help!
  • threepeasoupthreepeasoup Posts: 33Member
    threepeasoup said:
    Hey Player_E

    I am having the same problem right now. My ipad 2 and Iphone 3gs just updated to 5.0 and is running into this problem:

    Xcode cannot run using the selected device.

    This message only appears when I try to build and run the game.
    The version of iOS on “iphone” doesn't match any of the versions of iOS supported for development with this installation of the iOS SDK.
    The version of iOS on “ipad” doesn't match any of the versions of iOS supported for development with this installation of the iOS SDK.

    I am stuck! please help!

  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    do u have the newest version of xcode
  • threepeasoupthreepeasoup Posts: 33Member
    I have 4.1 on 10.6.8 Do I need to upgrade to snow leopard?
  • ChobbifaceChobbiface Posts: 491PRO
    @threepeasoup, you need to download xcode 4.2
  • threepeasoupthreepeasoup Posts: 33Member
    worked CBL! Thanks! Just saved me a night of no sleep.
This discussion has been closed.