Cannot Parse the Package - Android Publishing

AnunnakiCreatorsAnunnakiCreators Member Posts: 54
edited November -1 in Tech Support
More errors thank god with my app deployment this time, when going to verify that the app runs on Android versions I get the following error:

Cannot Parse the Package

I have been scouring the forums and everything that I have found has not worked in solving this. Specifically apkinstaller app.


  • AnunnakiCreatorsAnunnakiCreators Member Posts: 54
    Ok thanks for the response, Now I can stop pulling my hair out and work on something else.
  • pixel_knightspixel_knights Member Posts: 50
    Is there any update on this yet? I've just signed my first APK and getting exactly the same error? Cannot parse the package?
  • butterbeanbutterbean Member, PRO Posts: 4,315
    Use your signed apk for testing instead of the unsigned one, and that should render the problem :)
  • dreamgoaldreamgoal Member Posts: 9
    edited December 2011
    Alas no, I tried to run both signed and unsigned with my project and i get the same message
  • pixel_knightspixel_knights Member Posts: 50
    edited December 2011
    I tried running both, makes no difference, still the "Cannot Parse" message. If I try to upload the apk to the android market I get an error stating

    The package name of your apk is invalid. Package names must start with a character and can only contain characters, numbers, underscores and dots. They must have at least one dot, cannot end with a dot, and cannot contain any runs of more than one consecutive dot.

    /edit just noticed the "they must have at least one dot" part :)
  • lycettebroslycettebros Member, PRO Posts: 1,598
    Are we still waiting for a fix for the parse error as of 8th Dec (USA day time)??? This is the only thing holding me back from getting onto the market.

    I have solved the keystore and zipalign challenges - just this one last problem (other than the sound lag and no URL link support).
  • jkanalakisjkanalakis Member, PRO Posts: 49
    I'm seeing the same message on Kindle Fire: "There is a problem parsing the package." Has this been resolved or am I doing something wrong?

    John K.
Sign In or Register to comment.