GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Issue Notification: iOS 3.x no longer supported in latest Xcode

SaladStraightShooterSaladStraightShooter Austin, TxPosts: 3,081Member, Chef Emeritus
edited January 2012 in News from the Dev Team
Hello all,

After receiving inquiries via support regarding why the latest version of Xcode does not appear to function with viewers utilizing iOS 3.x, we felt it was necessary to offer an explanation and a point of clarification in this regard to keep our community informed.

After a short investigation on this, we discovered that Apple closed the loop-hole that previously allowed us to offer support for older iOS versions. (Such as 3.x).

While Apple officially dropped support for this iOS sometime back, they allowed companies such as GameSalad to implement a modification via supplementary code that allowed us to continue to offer support. With the addition of the latest version of Xcode, however, Apple has removed this option, thereby rendering this modification obsolete.

The reason your older GS Viewer may appear to work adequately is that it is structured such that the supplementary code is still in place, as it was distributed before the recent changes. However, the trade off is that it is unable to support iOS 5.x. Faced with the decision of abiding by the latest Xcode configuration, which allows for support of iOS 5.x, or maintaining the older version of Xcode, which still supported iOS 3.x, GameSalad has decided to pursue the more feasible option of full support of the latest devices, though this excludes some users still utilizing the older versions.

An important note as to why this decision was made was regarding the obvious expansion of newer devices in the market, with older iOS devices making up only 5% of the market. We feel being as up-to-date as possible is, and remains to be, the better course for GameSalad and it's community.

We apologize if this announcement negatively impacts your work, but hope that you will understand the reasoning behind it.

Cheers,
-SSS

Why do you keep using that word? I do not think it means what you think it means.

Comments

  • ultimaultima Posts: 1,207Member, PRO
    so when is 0.9.9.1 coming out again? lol j/k... does that mean publishing support for 3.x will be dropped soon as well? in which case, no point of having a armv7 check mark option..
  • 8BitAvrin8BitAvrin Posts: 361Member, PRO
    Hey SSS, I have the newest version of Xcode and iOS on my iPhone 4s, but ever since the new Gamesalad update happened a few days ago I get stuck at the "loading game" screen when I try to load a game on my device to test. I've been trying to get it to work throughout the day, reinstalling several times, but no luck. The viewer installs on the phone fine but I get stuck on the loading game screen on both the preview on the creator and on my device. Is there anything specific I need to do within the new version on Xcode or is there something else going on with the Gamesalad servers?

    WebsiteTwitter ∞ My apps are available on: Apple iOS App StoreGoogle Play App StoreAmazon App Store

  • MarkOnTheIronMarkOnTheIron Posts: 1,447Member
    @ultima said:
    no point of having a armv7 check mark option

    No, we will still need it because the iPhone 3 and the iPod Touch 2nd gen can run iOS4. The post's only implications are that the only unsupported devices (for now) will be the original iPhone (Edge) and the 1st gen iPod Touch.

    @SSS This post and your previous one have created and will create some confusion on what devices our GS created games will run on. The confusion is created by the device name (3, 4, etc.) and by the iOS name (2.x, 3.x, etc.). As I said the dropped support for iOS 3.x will only affect the 1st gen devices, other older devices like the iPhone 3 can run iOS 4.x and therefore can run our games (at least until Apple will drop support for iOS 4.x).
    I think it will be good to make an informative thread on the situation with supported devices.
    Something like:
    image

    and so on...
  • ultimaultima Posts: 1,207Member, PRO
    armv6 for the previous version rite?
  • zombieaddictzombieaddict Posts: 213Member
    so long as we can still build our games to work with 2g im fine with that
  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    Yeah guys this is dropping support for software not hardware. The iPhone 3G and IPod second gen are still supported hardware as long as they are running iOS 4.

    It's not my fault I never learned to take responsibility for anything. ;)

  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,904Member
    edited January 2012
    All good things come to an end. @zombie, lol fine with that? You don't have much choice this is tech it happens all the time. The life cycle of tech is shorter than a blowfly..lol. This is the tech business adapt or die, like it or not, it's always been the reality for 20+ years now.
  • zombieaddictzombieaddict Posts: 213Member
    i just say 2g because its the lowest i test on just to make sure my app will be as universally playable as possible. too many people complain about the performance of apps. at this point in time im optimizing my app to run its best even when on a 2g so the 4g+ crowd should have no issues whatsoever.

    yes apple does have to move on. i AM fine with that. i wouldnt be supporting some ancient piece of hardware that not many people use. (i only know one person that still uses a 1g and it was given to them for free). but the 2g is an important market still for us as developers to be targeting. just because the 4s is here doesnt mean that all the millions of 2g devices in the world that apple sold have disappeared. they are still out there, being used by people, still wanting to download apps.
  • creativeappscreativeapps Posts: 1,771Member
    Angry Birds, Cut The Rope, Fruit Ninja, Doodle Jump & many famous games are working fine on iOS 3.0 and 2nd gen ipod touch. I just want to know in next update its support iOS 3.0 and 2nd gen touch or not?
  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,904Member
    Second gen can run ios 4 so maybe
  • rassy9516rassy9516 Posts: 13Member
    hmm.. I have a iPod Touch 1g with iOS 3.1.3, and I really want to test my game on it so I can fix bugs, but i can't because it is not compatible:(
    Please make it work! I have the latest Xcode 4.0.
  • AtrevidoAtrevido Posts: 1Member
    Same problem as FutureNewbApps, I get stuck at the loading game screen on my device to test. Any solution?
This discussion has been closed.