Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Signed APK won't install on device.

I built the app, (GS for Win7) and finally got the APK signer working and got it signed and now I try to install it on my android device and the installation starts like normal and the name and icon comes up and then it just says "application not installed", no other error. Any ideas? I install apks from other app building software all the time with no issues.


  • The_Gamesalad_GuruThe_Gamesalad_Guru Posts: 9,914Member
    What device are you trying to install to? Try publishing the app out again and be sure on the device allow third party apps is on.
  • It's an AT&T Samsung Infuse 4G. My APKs from Andromo publish fine to it. I guess I could try publishing to the android store directly but don't really want my beta available to everyone. Should I be signing the apps with an older version of java than 1.7 maybe?
  • So I re-published from GS, rebuilt the project, downloaded the APK again and used the APK signer again. Still exactly the same issue. "application cannot be installed." Downloaded another apk to my device and installed it and it worked fine.
  • Has anyone managed to get something from GS for Windows on an Android Device yet? And if so please let me know how you did it. The "click here to sign your app" does not work in Chrome, IE, Safari or Firefox either. Basically, I'm not positive GS for Windows will actually publish at all.

    If not, and it works on MAC, I have a MAC also I can build from, guess that's next on the list...

    ...this seems like an unreasonable amount of work for something that should be simple. I've already put about 12+ hours into this. Why doesn't the server side sign the app and just ask for info at build time and send us a signed APK? (like andromo/seattleclouds/etc) But regardless, I just need to know how to get it done.
  • So I published to GS, and then built the APK and signed it using the Mac and then loaded that on the device and it worked. Could I then move the keystore to the PC from the Mac maybe? Going to try it later today.
  • So this is kind of log of my progress in case it helps anyone else.
    - I am unable to publish now from the Windows GS, however I am transferring the project onto a copy of GS on a different Windows machine to see if that works for publishing, if not then I will copy it to the MAC Book.
  • Vision Strike Ware LLCVision Strike Ware LLC Posts: 86Member
    edited November 2012
    Looks like the export all goes into one file. I'll have to mess with it some more and make sure everything makes it over to the Mac if I need to, to get it to publish.
  • Ok, same error, clean install on a new machine.

    An error was encountered when uploading project: System.Net.WebException:
    The operation was times out
    at System.Net.Http.WebRequest.GetResponse()
    at Game Salad.Xaml.Publishing.Projectupload.uploadFile_DoWork(Object sender, DoWorkEventArgs e)

    Going back to plan B, move to the Mac and see if that will publish...
  • Exporting the project from the PC with all the art, etc. Worked fine. Saved into a windows share, loaded that into Game Salad on the MAC and fixed a couple minor bugs, looks like the final scene gets portrait mode turned off. Publish, Sign it with the Keystore I made earlier, save the apks back to the windows share, plug the android into the windows machine, copy straight into the downloads folder and install on the android device. Voila. Victory!
  • PoisonSaintPoisonSaint Posts: 17Member, PRO

    Your the man Mattrouse1. I'm getting the same problem right now. I will use your method. I don't know if it'll work yet, but this is extremely helpful to know someone else have the same problem and solved it. Thanks a bunch buddy.

  • CodeMonsterCodeMonster ACT, AustraliaPosts: 1,078Member

    haha, same thing happening with me, i would sign my .ipa files and submit them to apple, i would also try install that .ipa on my device.
    but it wouldn't work, so i had to jailbreak

Sign In or Register to comment.