Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Published Universal Binaries no longer working?

allornothingallornothing Member, PRO Posts: 126
I have been publishing test versions of my game to iOS Universal Binary for months now, but as of today they not longer work. I've double checked everything, provisioning profiles etc. I generate the app, sign it successfully, bring it into iTunes and attempt to sync (i've also tried pushing to testflight) but just as the app installing progress bar is about to complete, I get the error "'Game' Failed To Install". This is happening on all devices on my provisioning profile.

I've rolled back to a previous verified working version of the game and attempted to publish that again. I've found that it will not install now either (and I have a previous .ipa that works fine), so I'm guessing something on the build server is not doing its job correctly?

I've tried uploading projects from GS Creator 10.1 and 10.3 with no luck. Help!


  • The_Gamesalad_GuruThe_Gamesalad_Guru Member Posts: 9,914
    Did you report this using the support link? This is the best way to inform the staff at GS.
  • allornothingallornothing Member, PRO Posts: 126
    Discovered the problem which whilst one on my end, does impact the publishing pipeline.

    Whilst all my provisioning profiles were all ok and valid, the developer signing certificate had expired (with no warning). Creating a new one seemed to do the trick, and I was back up and running soon. However, where this becomes an issue for GS is that when I downloaded and signed the app, it was met with 'success' and those blasted fireworks, when what really happened was that the signing certificate was invalid and not signing anything. There needs to be a check in the signing process that highlights this error and prompts the user to get it checked out :)

This discussion has been closed.