GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Stable Release - Macintosh GameSalad Creator 0.12.20

QASaladQASalad Posts: 142Key Master, Head Chef, Member, PRO GameSalad Employee

Stable Release - Macintosh GameSalad Creator 0.12.20

Features:

  • New in this version is account validation on Creator start. A valid account is one that was created through the GameSalad website, and has completed email validation. If you are having trouble logging into Creator, please be sure you have email validated your account. If you have not, reset your password, and it should validate your email that way. Validating your GameSalad account on start is necessary to access the full suite of features associated with your account permissions. Once you log into Creator using your GameSalad account credentials, you will stay logged in on that machine until you manually log out, so no need to do it every time. Once you have logged into Creator and your account has been validated, you may use Creator offline for up to 3 days before needing to log in again.

  • 64-Bit Support added for iOS Apps and the iOS Viewer

Fixes:

  • Memory clean-up and fixes for Mac creator. You should now notice decreased CPU usage and memory footprint in OSX Yosemite.

  • Fixed an issue that was causing submitted iOS apps to get rejected for not adhering to the new iOS Data Storage guidelines. Please re-generate any iOS apps with this build to fix the issue.

Known Issues:

  • iAds are only appearing at the top of the screen even if set to appear at the bottom (Bug 688)

  • For iOS 8 devices, if you are unable to connect to the iOS Viewer, try shutting down and restarting the device.

  • Android devices that use ipv6 will not be able to connect to the Android Viewer over WiFi. Please use the USB connection instead for the Viewer.

«13456711

Comments

  • QASaladQASalad Posts: 142Key Master, Head Chef, Member, PRO GameSalad Employee
    edited February 2015

    There is also an issue currently in Web Publishing where iPad and iPhone targets are not saving the Minimum OS Version. Until we get the fix in, use iOS Universal Binary or else you'll get rejected by Apple for not setting the version to 5.1.1.

    EDIT: This is now fixed. Minimum OS Version is now saving for iOS Universal, iPad, and iPhone.

  • LovejoyLovejoy Posts: 2,078Member

    Very nice!

    Fortuna Infortuna Forti Una

  • LumpAppsLumpApps Posts: 2,868Member

    Awesomeness!!

  • AlphaChannelAlphaChannel Posts: 3Member

    Great work team....

  • ChunkypixelsChunkypixels Posts: 1,113Member
    edited February 2015

    Bug regarding registering correct minimum iOS setting in the publishing portal seems to be back in this version... filing bug report...

    Dang!...just seen the yellow post mentioning it as I type.... won't bother with the bug report then. Good to know its already been spotted and flagged by the team :)

    @QA Salad Actually... the bug is happening for Universal builds too... any idea how soon this will be fixed?

    Edit: can't get my reply to link in QA Salad properly, is it because of the space in his name?

  • QASaladQASalad Posts: 142Key Master, Head Chef, Member, PRO GameSalad Employee

    Hmm. I just confirmed that iOS Universal is saving the OS version and i was able to successfully submit my app to Apple through Application Loader...

  • ChunkypixelsChunkypixels Posts: 1,113Member

    Ive just published using universal and tried both 5.0 and 5.1.1 as minimum iOS and the generated app will not install on devices using those OS...

    Worked fine a couple of hours ago when I tried with the previous stable release...

  • maurice_murphymaurice_murphy Posts: 15Member, PRO

    @QA Salad any news on when iads will be fix, my game (with 50+ levels) was build for iads to be at the bottom. Thanks.

  • MattButlerStudiosMattButlerStudios Posts: 486Member

    Memory Fix!!! :)

  • QASaladQASalad Posts: 142Key Master, Head Chef, Member, PRO GameSalad Employee

    So it looks like 5.1.1 is the minimum for submission but 64bit apps are only supported by 6.0 or higher..... That is so Apple that it makes my brain hurt. Anyway, looks like it's 6.0+ or bust now.

  • LovejoyLovejoy Posts: 2,078Member

    @QASalad said:

    So it looks like 5.1.1 is the minimum for submission but 64bit apps are only supported by 6.0 or higher..... That is so Apple that it makes my brain hurt. Anyway, looks like it's 6.0+ or bust now.

    So as of right now we still can't submit apps then?

    Fortuna Infortuna Forti Una

  • BlackCloakGSBlackCloakGS Posts: 2,250Key Master, Head Chef, Member, PRO GameSalad Employee

    Yes the min OS need to be 6 and we are working on the fix right now.

  • QASaladQASalad Posts: 142Key Master, Head Chef, Member, PRO GameSalad Employee

    @Lovejoy said:
    So as of right now we still can't submit apps then?

    You totally can. Just make sure the minimum OS version is at least 5.1.1. To actually run the app on your device, you'll need a device with iOS 6.0 or higher though.

  • LovejoyLovejoy Posts: 2,078Member

    @BlackCloakGS said:
    Yes the min OS need to be 6 and we are working on the fix right now.

    Gotcha, thank you.

    Fortuna Infortuna Forti Una

  • ChunkypixelsChunkypixels Posts: 1,113Member
    edited February 2015

    Cheers for the update. looks like its finally time to drop support for the iPad 1st Gen, whether we like it or not..

    It was bound to happen at some point. Might as well just support ios7 and above devices now... :neutral:

  • mshuraih mshuraih Posts: 175Member, PRO

    thanks for all the work GS team .. just wondering what about iAd appearing on the top .. any plans for soon fix?

  • QASaladQASalad Posts: 142Key Master, Head Chef, Member, PRO GameSalad Employee
    edited February 2015

    Okay the issue with iPad and iPhone targets not saving Minimum OS Version is now fixed in web publishing. Should be good to go.

  • greenentcogreenentco Posts: 12Member, PRO

    is the iAds fixed? My ads are showing on the bottom :smiley:

  • greenentcogreenentco Posts: 12Member, PRO

    nevermind... iAds only show on bottom with iPhones lower than the 6

  • 921creative921creative Posts: 140Member, PRO

    According to this article, only 3% of device users are running an iOS version lower than 7. I wouldn't worry about people not being able to run your game.

  • 2create2create Posts: 90Member, PRO

    Can't wait for iAd fix! Thanx

    Yops – the innovative puzzle game for iOs – http://apple.co/1ESvIlC
    Other games - http://appstore.com/flashpromllc/

  • ChunkypixelsChunkypixels Posts: 1,113Member

    @QASalad just had my Universal binary rejected. I selected minimum iOS 7, but apparently the build is registering as 5.1 once its uploaded to Apple... thus conflicting with the info.plist

    So its still an issue...

    Apple email text below:

    Dear developer,

    We have discovered one or more issues with your recent delivery for "Astro Hop". To process your delivery, the following issues must be corrected:

    Minimum OS Version Mismatch - The minimum OS version (LC_VERSION_MIN_IPHONEOS) in the binary ('5.1') for architecture ('armv7') differs from the MinimumOSVersion ('7.0') in the Info.plist.

    Once these issues have been corrected, you can then redeliver the corrected binary.

    Regards,

    The App Store team

  • SocksSocks London, UK.Posts: 12,822Member

    @921creative said:
    According to this article, only 3% of device users are running an iOS version lower than 7. I wouldn't worry about people not being able to run your game.

    I also suspect that people who don't keep up with the latest OS are likely to also be people who don't buy a lot of apps . . . . ? So of that lost 3% only a much smaller fraction would have been potential customers . . . ?

  • jigglybeanjigglybean Posts: 1,584Member

    @Socks said:
    I also suspect that people who don't keep up with the latest OS are likely to also be people who don't buy a lot of apps . . . . ? So of that lost 3% only a much smaller fraction would have been potential customers . . . ?

    Not totally true. Whilst it is small numbers, think of how many countries deemed 'third world' are now catching up with tech. India springs to mind

    Like Balls? Then click here! We've 100 coming soon

  • djdeedjdee Posts: 180Member

    i finished my game and am just waiting for iAds issue to be fixed. Any idea how long will it take to fix it?

  • unbeatenpixelunbeatenpixel Game Developer Posts: 530Member, PRO

    Thanks for the stable release. I will wait iads issue to be fixed.

    Check out my games on the App Store!

    Startup Grave / Wordgraphy / Polycolor / 20 Seconds / Minimal Maze / Lokum

  • UtopianGamesUtopianGames Posts: 5,685Member

    When will the PC be up to speed 0.12.20? I'm a mac user but i get constant emails about the PC always being behind.

  • jigglybeanjigglybean Posts: 1,584Member

    Thanks GS people! Works a treat on Yosecr*p now. I can do more things before it runs out off puff, which probably more to do with iMacs being naff than GS.

    Like Balls? Then click here! We've 100 coming soon

  • Thunder_ChildThunder_Child Posts: 2,343Member

    This release sure fixed my memory leaking issue or whatever it was the slowed production down after 10-15 mins.

    Thank you...

  • QASaladQASalad Posts: 142Key Master, Head Chef, Member, PRO GameSalad Employee
    edited February 2015

    @Chunkypixels said:
    QASalad just had my Universal binary rejected. I selected minimum iOS 7, but apparently the build is registering as 5.1 once its uploaded to Apple... thus conflicting with the info.plist

    So its still an issue...

    Apple email text below:

    Dear developer,

    We have discovered one or more issues with your recent delivery for "Astro Hop". To process your delivery, the following issues must be corrected:

    Minimum OS Version Mismatch - The minimum OS version (LC_VERSION_MIN_IPHONEOS) in the binary ('5.1') for architecture ('armv7') differs from the MinimumOSVersion ('7.0') in the Info.plist.

    Once these issues have been corrected, you can then redeliver the corrected binary.

    Regards,

    The App Store team

    That's totally weird because in the apps I generated last night the LC_VERSION_MIN_IPHONEOS is 7.0. Did you re-generate the app after the fix? Just making sure because you will need to do that.

    EDIT: Nevermind. Legit bug on our side. We'll have a fix out as soon as possible.

Sign In or Register to comment.