GS stop recognizing viewer for my phone

Player_EPlayer_E Member, PRO Posts: 604
edited November -1 in Tech Support
I booted up GS today to test some new features I added into my game. When I launch the GS viewer GS does not recognize it and does not give me the option to connect to my device. My phone on the other hand does not say "unable to find connection" like it does if there is an issue.

I have quit out of GS and rebooted, still does not work.
I have restarted my Mac and rebooted, still does not work.
I restarted my iPhone, still does not work.
I uninstalled the viewer on my iPhone and rebuilt it with xCode, still does not work.

Any clue as to what is going on? I was testing last night with no issues at all.

(My device and Mac are both on the same network)


  • ktfrightktfright Member Posts: 964
    Do you have an iPhone 4?
  • quantumsheepquantumsheep Member Posts: 8,188
    The provisioning profile may have expired. I've got the same problem.

    Usually we get an update to the viewer every month or so, so this problem never arises as you have to build a new viewer with a new provisioning profile.

    However, it's been about three months now, so the profile may have expired.

    Hope that helps,


    Dr. Sam Beckett never returned home...

  • Player_EPlayer_E Member, PRO Posts: 604
    I have a 3GS,

    Now GS gives me the option to connect to device, but my device does not even have the GS viewer open. and when I do open it and try to connect it simply just sits there and does not load.

    Wonder what the deal is.
  • Player_EPlayer_E Member, PRO Posts: 604
    I actually just renewed all my profiles 3 days ago when I renewed my license with apple, so that cannot be the issue, besides last time my profile expired my iPhone actually gave me an alert saying it was expiring in about 10 days.

    i have not received any message of the sort for almost 5 months.
  • Player_EPlayer_E Member, PRO Posts: 604
    well I tried all that, but still having issues.

    Im leaving for the day was hopeful that I could get some testing in before, but looks like i'll have to wait to see if it is working tomorrow :(
  • Player_EPlayer_E Member, PRO Posts: 604
    Still having the same issues, any one have a similar issue that can help out??

    this is really frustrating...
  • chuckychucky Member Posts: 13
    Hi Player_E

    This has just happened to me as well today.

    I've re-installed GameSalad. Rebooted the Mac, the iPhone - both of them (I have an old 3G and a 4). I also rebuilt the viewer using the 4.1 SDK on the old 3G - still no luck.

    My profiles still have about 25 days left, so that's not the problem either.

    Any help would be greatly appreciated.
  • daverennerdaverenner Member Posts: 133
    I had similar problems. I turned off the wi-fi on my ipod then back on and it connected with GS no problem.
  • chuckychucky Member Posts: 13
    Hi Dave

    Thanks for the suggestion - I tried it but still no go unfortunately.

    Most of the time the Preview on iPhone button doesn't show up anymore and when it does, GameSalad says connecting to device... and the iPhone says Waiting for connection...
Sign In or Register to comment.