New GameSalad functions [User Feedback Needed]
CodeMonkey
Head Chef, Member, PRO Posts: 1,803
Hello Community.
I'd like some feedback on format on new functions for the expression editor.
If there was a new function with the format
newFunction(x,y,"[yes|no|maybe]",z)
would it make enough sense that you would need to have one of the 3 specified values in the 3rd input and result in one of these functions:
newFunction(x,y,"yes",z)
newFunction(x,y,"no",z)
newFunction(x,y,"maybe",z)
newFunction(x,y,game.YNM,z) where game.YNM is a text attribute that has the value "yes","no","maybe"
Its starting to fall over to the "programming side", but I think it would help make functions more powerful. There will be documentation to describe how new functions work, and new templates that use them.
Is it clear enough for programmers and non-programmers alike that you must choose one of the 3 options within the "[ ]"?
Is it too much text for a function to have all of that extra text for the options? (We can stretch out the expression editor for the default view)
Edit:
Example--So in the drop down function selector you would see:
max
min
mod
newFunction
padInt
(it would not really be named "newFunction", it is just for this example. It could be named "doMyHomework") when you select "newFunction" from the drop down, it returns a format state above. It could have more or less parameters. But the new thing would be the required text values for a parameter in a certain spot.
I'd like some feedback on format on new functions for the expression editor.
If there was a new function with the format
newFunction(x,y,"[yes|no|maybe]",z)
would it make enough sense that you would need to have one of the 3 specified values in the 3rd input and result in one of these functions:
newFunction(x,y,"yes",z)
newFunction(x,y,"no",z)
newFunction(x,y,"maybe",z)
newFunction(x,y,game.YNM,z) where game.YNM is a text attribute that has the value "yes","no","maybe"
Its starting to fall over to the "programming side", but I think it would help make functions more powerful. There will be documentation to describe how new functions work, and new templates that use them.
Is it clear enough for programmers and non-programmers alike that you must choose one of the 3 options within the "[ ]"?
Is it too much text for a function to have all of that extra text for the options? (We can stretch out the expression editor for the default view)
Edit:
Example--So in the drop down function selector you would see:
max
min
mod
newFunction
padInt
(it would not really be named "newFunction", it is just for this example. It could be named "doMyHomework") when you select "newFunction" from the drop down, it returns a format state above. It could have more or less parameters. But the new thing would be the required text values for a parameter in a certain spot.
Comments
Guru Video Channel | Lost Oasis Games | FRYING BACON STUDIOS
If the Y,N,M was a drop down list that would be obvious you had to select one. If it's normal text that you enter manually I think some people may get confused by the new system initially. i.e they'd think an update had broken their game or something. But I guess an alert when you first open a GS update would help with that + forum posts + easily accessible documentation.
Also I'm ok with adding ynm via text, but a lot of people are going to forget or not know to do it without a drop down box to pick from.
This is just a generic example. So in the drop down list of functions you would see the function "newFunction" (like sin,cos,pow) and when selected it would give you newFunction(x,y,"[yes|no|maybe]",z) in the expression editor for you to modify.
@HoneyTribeStudios these would be for entirely new functions not modifications of existing ones. So no break in old projects. Y,N,M would not in the drop down list, but part of the function.
I can however see how for some peoples it could be harder to understand, but if you also release a thorough documentation on how it works then you should be ok.
It's cool that you're introducing new expressions ! Looking forward to what you guys come up with.
I'd go with a drop-down too, most people recognise the drop-down convention, it's fairly universal, so I imagine it would be pretty obvious what you need to do.
(Obviously the drop-down would access Yes / No / Maybe / Attributes.)
My 14year old son, who doesn't use gamesalad, thinks it's clear. He adds that in text he often sees a slash used instead of a vertcal bar.
@kolabo Awesome. Thanks for that double feedback.
Ah! Ok, then I think how you have it shouldn't be too difficult for people to adapt to.
- Thomas
Send and Receive Data using your own Server Tutorial! | Vote for A Long Way Home on Steam Greenlight! | Ten Years Left
My GameSalad Academy Courses! ◦ Check out my quality templates! ◦ Add me on Skype: braydon_sfx
http://jamie-cross.net/posts/ ✮ Udemy: Introduction to Mobile Games Development ✮ Learn Mobile Game Development in One Day Using Gamesalad ✮ My Patreon Page
Hi @CodeMonkey
I don't understand what use a Yes,No,Maybe would be used for when applied to a boolean attribute, except in the sense of Yes,No,Either ; would they be the same thing?
And if it is just Yes,No,Either, as this doesn't take much programming at all to achieve at the moment, I'm wondering if it would be worth it to implement as a function; but that's just me...
For something like one of your examples too: newFunction(x,y,game.YNM,z) the same thing springs to mind, not sure of it's usefulness, sorry if I've missed the point here! Be interested in some practical examples too, thank you. :-)
""You are in a maze of twisty passages, all alike." - Zork temp domain http://spidergriffin.wix.com/alphaghostapps
If people can use
Cellvalue(table,row,col)
Or
Magnitude(x1-x2,y1-y2)
Then using newFunction(x,y,"[yes|no|maybe]",z) should not be problem at all, and even if it is, after 3 times using it and testing it everybody will get used to it..
I wonder however.. What is it?!
Roy.
If we look at a current function, such as random, it appears as random(x,y). @CodeMonkey is just asking if new functions (or even current functions) should be shown with something to explain possible values better than simply listing 'x' and 'y'.
I think it's a good idea AND I think some people will be confused. But forward we go!
New to GameSalad? (FAQs) | Tutorials | Templates | Greenleaf Games | Educator & Certified GameSalad User
@gyroscope this is just an example of what new functions would look like with options. I think I had evite answers on my mind.
Whatever option interferes the least with concatenating or programmatically inserting a variable. When you are done, Teach us how to do it, and we will adapt.
""You are in a maze of twisty passages, all alike." - Zork temp domain http://spidergriffin.wix.com/alphaghostapps
Now that I understand, a +1 from me!
Roy.
I'm a bit useless at this until I see a solid example in front of me, but my initial thought was:
Why is the YNM value placed 3rd in the line?
For now, you have newFunction(x,y,game.YNM,z)
Why not newFunction(game.YNM,x,y,z)
or
newFunction(x,y,z,game.YNM)
?
Or am I just being spectacularly stupid here?
QS :
D
Dr. Sam Beckett never returned home...
Twitter: https://twitter.com/Quantum_Sheep
Web: https://quantumsheep.itch.io
Dr. Sam Beckett never returned home...
Twitter: https://twitter.com/Quantum_Sheep
Web: https://quantumsheep.itch.io