GameSalad

Actors turn into default squares when i click play

tonyy_wtonyy_w Posts: 6Member

Hey all,
I don't really know where to post this question so please excuse me if i posted it in the wrong category.
So.. today is my first day using GameSalad and so far it seems very nice. My only problem is: i follow all the instructions in the tutorials and when i change the images of the actors it is all fine until i click play. When i click play my player turns into a white square and my other actors turn to basic squares too. All i can do is change their colours. The guys in the videos don't have this problem.
I searched on the forum but i can't seem to find an asnwer. Please help me.
Thanks in advance and sorry if that has been posted many times.

Comments

  • jamie_cjamie_c ImagineLabs.rocks Posts: 5,315Member, BASIC

    Maybe the images are corrupt or have become un-linked. Try re-saving and re-importing the image(s).

  • tonyy_wtonyy_w Posts: 6Member

    I tried 20 different images and none of them work (i tried the images from the gamesalad course too). I started new projects, closed GS and etc. I still have this problem.. :(

  • pHghostpHghost London, UKPosts: 2,061Member

    Can you record a video of it?

  • tonyy_wtonyy_w Posts: 6Member

    I just shot a quick video with my phone so you can get the idea. Please excuse me but i don't have any programes for recording on my PC atm

  • jamie_cjamie_c ImagineLabs.rocks Posts: 5,315Member, BASIC
    edited February 27

    That's very strange, I've never seen it happen to every actor at the same time. I'd contact tech support through the chat system, by clicking the blue bubble in the bottom right corner of the website.

  • tonyy_wtonyy_w Posts: 6Member

    Thanks Jamie_c, i will try that :)

  • Braydon_SFXBraydon_SFX Posts: 8,960Member, Sous Chef, PRO, Bowlboy Sidekick GameSalad Employee

    Got the request and we're looking into it now. :)

  • ToqueToque Posts: 998Member, PRO

    that's strange!!

  • tonyy_wtonyy_w Posts: 6Member

    Still no answer :/

  • ToqueToque Posts: 998Member, PRO

    There are little quirks sometimes. I usually save, quit GS. Restart computer and it goes away. But I can't say I've ever started a new game. Drag in a PNG and hit play and it doesn't show up. ?????

  • pHghostpHghost London, UKPosts: 2,061Member

    Does it happen even when you disable the animation behavior?

    Do you have any other rules in the actors that set or modify the image?

  • tonyy_wtonyy_w Posts: 6Member

    I don't have other rules in the actors and yes it still happens when i disable animation behaviour :/

  • Braydon_SFXBraydon_SFX Posts: 8,960Member, Sous Chef, PRO, Bowlboy Sidekick GameSalad Employee

    I think I've seen this happen with this same project for some reason.

    Try deleting all of your images, saving the project and closing GameSalad. Then open your project again and import an image that is not part of the art you got when following the tutorial. Take that image and apply it to a new actor and preview. I want to say I've seen this happen before for this same tutorial; the images may be corrupt.

  • eberlepetereberlepeter Posts: 8Member, PRO

    I have the same problem with single actors/images but it only apears on the smartphone (Android). On the PC everything looks fine and the images get shown like I want them to. But if I play my app on the phone some images are just white boxes...
    I tried different solutions but nothing worked. I edited the image files and changed values, data type etc. but it had no effect. The strange thing is, that I created these images like others that get shown and I have no problems with...
    I´d apreciate some feedback too.
    Thanks for the great community in advance!
    Keep on gaming!

  • eberlepetereberlepeter Posts: 8Member, PRO


    For better understanding i made pictures:
    the picture of the screen with the cracks on the display is on the smartphone and the picture of the screen without cracks is the monitor of the pc

    I dont get it why the image gets displayed correctly on one screen/device and buggy on the other...

  • pHghostpHghost London, UKPosts: 2,061Member

    Try taking the images, open them in Photoshop or something similar and Save As...

    That will generate new images. Name them the same and keep the file type. Reimport them. It is possible that the ones you are using, if they are PNGs, were 'optimized' to make them smaller. That used to be OK, but at some point I know that GS support for 'optimized' PNGs became really hit and miss.

  • eberlepetereberlepeter Posts: 8Member, PRO

    Thanks for the tip but I tried it in the past and I tried it now again and it doesn´t work.
    I tested PNGs and JPGs (optimized and not optimized).
    The strange thing is, that other pictures, edited in the same way get shown without any problem, but some are bugged...
    Is there the "perfect format" for images (data type, values of the picture etc.) that works in every case?
    What are your experiences?
    What are the best formats etc.?
    Thanks for the great community here and keep on gaming!

  • ToqueToque Posts: 998Member, PRO

    @eberlepeter said:
    Thanks for the tip but I tried it in the past and I tried it now again and it doesn´t work.
    I tested PNGs and JPGs (optimized and not optimized).
    The strange thing is, that other pictures, edited in the same way get shown without any problem, but some are bugged...
    Is there the "perfect format" for images (data type, values of the picture etc.) that works in every case?
    What are your experiences?
    What are the best formats etc.?
    Thanks for the great community here and keep on gaming!

    Uncompressed PNG has never failed me

  • pHghostpHghost London, UKPosts: 2,061Member

    @eberlepeter said:
    The strange thing is, that other pictures, edited in the same way get shown without any problem

    Yeah, if that is the case, you really are looking at a image corruption problem, not a GS bug.

Sign In or Register to comment.