GameSalad

Help - Scene change fails if calling for interstitial ad.

DigiChainDigiChain Posts: 1,117Member, PRO

Ok, this is driving me mad and I can't seem to find an answer.

In my game after x time a scene change is triggered to deliver an advert.
In the scene change rule I have a Show Interstitial Ad. When testing on device this scene change never happens, and any further scene change rules after this also fail.
If I have Show No Ad in the same scene change rule the scene change triggers as expected.

To rule out bad code I've created a brand new project with two buttons - on touch one changes the scene with an advert, the other changes the scene without an advert. Again in a build only the one without an advert triggers the scene change!
I've also tried turning off internet connection on my device to see if the ad provider is the cause of the issue - but still it fails.
I'm attempting to use Chartboost for the interstitials (which I've integrated into many projects previously with no issues).

I'm stumped! Any thoughts?...

Comments

  • ArmellineArmelline Posts: 4,382Member, PRO

    This can happen if the ads aren't set up correctly - for example if you've not got test mode active.

  • DigiChainDigiChain Posts: 1,117Member, PRO

    Hi Armelline, I'm pretty sure this isn't the case - test mode is running on Chartboost. I've also removed internet connection so as to rule out the ad provider (the scene should just change without ad).

    Strange thing is that it was changing scene and delivering ads fine until yesterday... and as I said I've created a brand new project with just scene change rules to test - and the scene changes with interstitial ads don't work.

    Note: this only happens on device, within creator everything seems to be running fine.

  • DigiChainDigiChain Posts: 1,117Member, PRO

    Issue sorted - it was ad network related.
    I ended up deleting my app from Chartboost and then setting up again fresh. Not sure why this worked, but it did.

  • ArmellineArmelline Posts: 4,382Member, PRO

    Glad you got it sorted! When I encountered is previously we fixed it in the same way - but I wasn't able to narrow down what the exact cause was other than "something in the setup of the ad network," unfortunately!

  • dariusimmanuelguerrerodariusimmanuelguerrero Posts: 18Member, PRO
    edited April 21

    faced with the same problem. game over scene doesnt happen when internet connection is on :( using chartboost too

  • DigiChainDigiChain Posts: 1,117Member, PRO

    For me it definitely seemed to be an issue with the ad network setup. Try deleting your app in the Chartboost dashboard, setting up as a new app again and then using the new Chartboost IDs when publishing - it worked fine once I'd done that!

Sign In or Register to comment.