GameSalad

IPhone publishing requires the latest iPhone SDK

situationcomediesituationcomedie Posts: 8Member, PRO

Hello I am just trying to test a game on an Ipad 2, using the latest version of gamesalad, xcode 8.2.1 and Elcapitan, which is the latest version of the os that my mac can handle. I am getting blocked at what I belienve is the end of the process with this prompt : IPhone publishing requires the latest iPhone SDK. Is it really that I need xcode 8.3 (and another 2 days of download because it is pretty slow where I am) and therefore sierra which means a new mac, to try my game ?
Or is there something else that I could be doing wrong. This is the first time I am trying to publish.
Tx
TAC

Comments

  • ToqueToque Posts: 729Member, PRO

    Hmmm. I used El Capitan and 821 Xcode a few days ago and no problems. ?? I will when I have a second. I know they were doing maintenance this weekend.

  • situationcomediesituationcomedie Posts: 8Member, PRO

    Ok, sort of reassuring. Who was doing maintenance GS ?

  • situationcomediesituationcomedie Posts: 8Member, PRO

    Are you using the last gs version as well?
    Thank you so much for taking the time.

  • ToqueToque Posts: 729Member, PRO
    edited April 14

    No Apple was doing maintenance. I didn't read the specifics. I just did a adhoc test publish and loaded on my iPhone with no problems or warnings....... I am using the same specs you gave.

  • situationcomediesituationcomedie Posts: 8Member, PRO

    Weird I must be doing someting wrong somwhere. Am I supposed to import the ios simulators on xcode ?

  • ToqueToque Posts: 729Member, PRO

    @situationcomedie said:
    Weird I must be doing someting wrong somwhere. Am I supposed to import the ios simulators on xcode ?

    I don't think so.
    Your testing adhoc?

    First time?

  • ToqueToque Posts: 729Member, PRO

    The two days to download could be a problem????

  • situationcomediesituationcomedie Posts: 8Member, PRO

    well it's slow at me work place, so I have to go download xcode at home, which there take an hour. But for my game, that is very light, the publishing process doesn't seem to be slowed down, The rest of the process goes pretty fast. And I get the prompt right away, so I don't think it's linked to broadband.

  • ToqueToque Posts: 729Member, PRO

    @situationcomedie said:
    well it's slow at me work place, so I have to go download xcode at home, which there take an hour. But for my game, that is very light, the publishing process doesn't seem to be slowed down, The rest of the process goes pretty fast. And I get the prompt right away, so I don't think it's linked to broadband.

    Sorry I thought the publishing your game part of it was taking hours. Yes Xcode is a huge download!!!

  • situationcomediesituationcomedie Posts: 8Member, PRO

    here is the answer of the tech support :
    **Yes, you do need to install the latest version of Xcode whenever you publish your game. :\ **

    I am frustrated right now that the only solution is me buying a new computer to export an 8bit game on an ipad 2.
    If anyone has an idea of something that I would be doing wrong, or has an hint for a fix I would be very very grateful.
    b

  • ForumNinjaForumNinja Posts: 417Key Master, Head Chef, Member, PRO GameSalad Employee

    @situationcomedie You may be able to use a 3rd party service like MacInCloud for virtual access to a newer Mac without having to drop the money for a new computer.

Sign In or Register to comment.