GameSalad

Game images missing after ad shows

So I have an app which I've finished, signed, and downloaded. It has Admob & Chartboost ads in it.

Everything works fine until the first intersetial ad shows. The ad pops up and after I click out of the ad all the game images are missing. It just shows black boxes.

The weird thing is it works fine if ads aren't included. Any ideas on what's causing this?

Also sometime the ads don't show at all and the game just freezes where it supposed to show an ad.

Comments

  • 8BitAvrin8BitAvrin Posts: 346Member, PRO
    edited June 19

    Any thoughts on this Gamesalad? I'm having the same issue using Admob & Revmob, except the last sentence. The ads show but after I exit out of the interstitial ad and the next scene loads, most of the images are missing, but the actors are still there because I can click on them and get a response & etc. Everything works fine when ads aren't included.

    Update: I've narrowed it down to Admob video/interactive ads causing the issue of images not loading on the next scene, crashes & etc. When I unselected video ads from Admob everything works fine, but this isn't that good of news because video ads are the highest earner. However, even though I've unselected video ads from Admob sometimes they still show up and when they do the issues arise again......

  • ToqueToque Posts: 849Member, PRO

    @8BitAvrin said:
    Any thoughts on this Gamesalad? I'm having the same issue using Admob & Revmob, except the last sentence. The ads show but after I exit out of the interstitial ad and the next scene loads, most of the images are missing, but the actors are still there because I can click on them and get a response & etc. Everything works fine when ads aren't included.

    Update: I've narrowed it down to Admob video/interactive ads causing the issue of images not loading on the next scene, crashes & etc. When I unselected video ads from Admob everything works fine, but this isn't that good of news because video ads are the highest earner. However, even though I've unselected video ads from Admob sometimes they still show up and when they do the issues arise again......

    Same. Admob. Unselect video adds and it seems to work for me.

  • adent42adent42 Posts: 716Key Master, Head Chef, Executive Chef, Member, PRO GameSalad Employee

    I'm guessing playing the video is doing something graphics memory that's killing the images. We'll need to try and repo. If you could log a bug on bugs.gamesalad.com and link the publishing portfolio page for your games (so we have a repo case).

    Also, could you let us know what devices you're using? Otherwise, I'd see if any of the images can stand to be bit blurry and make them smaller (pixel size, not file size). See if that prevents or helps the issue.

  • ToqueToque Posts: 849Member, PRO
    edited June 20

    Older builds with admob I have no problems. Seems only my latest build. I should of taken a screen shot. 80% of images/actors? were gone. I don't like video adds in my games anyways. I just turned off video adds in admob.

  • JapsterJapster Posts: 297Member, PRO

    hmmm.... wondering if this is also related to @Hideki Matsui 's issue I found?

  • kiemtienmuabim6kiemtienmuabim6 Posts: 6Member, PRO

    I have the same problem. After video Admob shows, some images of next scene will disappear :(

Sign In or Register to comment.