GameSalad

Big problem with ads

civocivo Posts: 4Member, PRO
edited September 16 in Working with GS (Mac)

Hello

I have a big problem with ads in my game.
I have add Admob og chartboost to my game.

I have add a "show banner" on the background og my first scene (menu)
on my menu I have 3 buttons.

and I have add when scene change a "interstitial ad"

I upload my game to gamesalad and setup all thing in web browser (ad unit ID)
I generate and sign my game to ios
upload it to itunesconnect og try the game with TestFlight

my game load and go to my menu (scene 1)
In the bottom, my game show my admob ad!
so my ads work!

BUT now I can not touch any for my buttons!!!
I can only touch the ad! only the ad work!

Now I go to game salad and remove admob and chartboost ad and I generate and sign my game to ios.
Upload it to itunesconnect og test it with testflight

And now my game work fine, but without ads :neutral:

If I try to add startup ad, my game dont startup, I only get a black screen

HELP!!!!

Comments

  • gingagaminggingagaming FREELANCE GS DEV Posts: 1,484Member, PRO

    Sounds like a chartboost issue. Ive noticed that recently Chartboost Ads freeze Gamesalad games if the internet connection is slow or weak. It also freezes the game completely if you PAUSE the campaign which is crazy bad. You used to be able to pause a campaign and the ads would stop, then unpause and the ads carry on but now, if you compile an app with the Chartboost SDK, you have to have a campaign running or it will break your game. It doesn't know how to handle "campaign paused" callback or a "missing campaign". It just freezes your game. Because of which, I've now flipped over to admob for banner ads instead now until Chartboost sorts it out but if I'm honest, I don't even thing GS or Chartboost know of the issue.

    In the past Gamesalad used to have a close relationship with chartboost so ill tag @adent42 so he can maybe speak to Chartboost to solve the issue

    In your case, try removing the Chartboost but keep Admob in and see what happens.

  • civocivo Posts: 4Member, PRO

    yes, it is a chartboost issue.

    I have remove chartboost, and now it work

Sign In or Register to comment.