GameSalad

Error with App submission to iTunes (Can't open support ticket - please help) - Error ITMS-90503

megumimegumi Posts: 14Member, PRO

Hi,

I tried to open a support ticket for this issue but the link to the support form for PRO users isn't working. Can someone please help with this problem I have with submitting apps. When I try to submit my app to iTunes, I get an error message that says

"Error ITMS-90503 "Invalid Bundle: Apps that have 'arm64' in the list of UIRequiredDeviceCapabilities in info.plist must only contain the arm64 slice".

This is the first time I have seen this error. I submitted a few Gamesalad apps to iTunes successfully this week without this error message so I don't know why this is happening. Can someone please help me with any ideas on how to fix this.

Cheers

Comments

  • DigiChainDigiChain Posts: 1,151Member, PRO

    I think the arm64 issue has been addressed in this thread:
    http://forums.gamesalad.com/discussion/95712/state-of-gamesalad-on-11-13-2017/p1

    @ForumNinja - I've mentioned elsewhere that PRO support isn't working, The PRO support link should be removed if GS no longer offers this. We get this message when attempting to use PRO support:
    Bummer. It looks like the help center at gamesalad.zendesk.com no longer exists.

  • megumimegumi Posts: 14Member, PRO

    Thanks DigiChain. I will check out the thread to see if someone has found a solution.

  • megumimegumi Posts: 14Member, PRO
    edited November 24

    Hi, I couldn't see a solution mentioned in that thread as to how to fix this error. I noticed others such as Phamtastic and Armelline are having the same problem. I hope this issue gets resolved soon because iTunes wont accept an app with this error message.

  • BobDBobD Posts: 374Member, PRO

    ERROR ITMS-90530: "Invalid MinimumOSVersion. Apps that only support 64-bit devices must specify a deployment target of 8.0 or later. MinimumOSVersion in 'Chi Chimes Timer.app' is '7.0'."
    ERROR ITMS-90098: "This bundle is invalid. The key UIRequiredDeviceCapabilities contains value 'arm64' which is incompatible with the MinimumOSVersion value of '7.0'."
    ERROR ITMS-90208: "Invalid Bundle. The bundle Chi Chimes Timer.app does not support the minimum OS Version specified in the Info.plist."

  • BobDBobD Posts: 374Member, PRO
    edited November 27

    ** Still Not Working ** GameSalad Publishing just changed and now MinimumOSVersion value of "8.0"
    But after upload of my app
    it gets dropped in the iOS Build!!
    The build never gets added.

  • rico240rico240 Posts: 14Member, PRO

    Any updates on the fix of this Arm64 error? This is upsetting because everything worked fine for me last week on Xcode 9.1, GameSalad 1.25.80 too & I didn't update to high sierra.

  • dapiondapion Posts: 316Member, PRO

    Same ITMS Error by me too

  • Same error..

    "Error ITMS-90503 "Invalid Bundle: Apps that have 'arm64' in the list of UIRequiredDeviceCapabilities in info.plist must only contain the arm64 slice".

  • dyoh777dyoh777 Posts: 13Member, PRO

    I have the same problem now although it worked a few days ago with xcode 9.1, sierra, and latest gamesalad client

    description length:1359731
    ERROR ITMS-90503: "Invalid Bundle. Apps that have 'arm64' in the list of UIRequiredDeviceCapabilities in Info.plist must only contain the arm64 slice."
    ERROR ITMS-90098: "This bundle is invalid. The key UIRequiredDeviceCapabilities contains value 'arm64' which is incompatible with the MinimumOSVersion value of '7.0'."

  • jinedjined Posts: 39Member, PRO

    Here a different error:

    Missing Info.plist value - A value for the Info.plist key 'CFBundleIconName' is missing in the bundle

  • ForumNinjaForumNinja Posts: 515Key Master, Head Chef, Member, PRO GameSalad Employee
    edited November 28

    @rico240 @dapion @candemirag@candemirag.com I believe the arm64 error should be fixed so long as you do the following:

    1. Head to your portfolio page for you app (and locate the Minimum Supported OS Version field)

    2. Make sure the value in the field is 8 and not 7

    3. If it's showing as 7, try performing a hard refresh (command+shift+r for Mac and control+shift+r for Windows)

    4. Verify that the value is now 8

    5. If so, re-generate / sign your app to see if the error is fixed

  • dapiondapion Posts: 316Member, PRO

    Tried...but not working.
    One error will be shown.

    ERROR ITMS-90503: "Invalid Bundle. Apps that have 'arm64' in the list of UIRequiredDeviceCapabilities in Info.plist must only contain the arm64 slice."

    In the Portfolio is the OS Version with 8.0 displayed.

  • -Timo--Timo- Posts: 2,309Member, PRO
    edited November 28

    Thanks @ForumNinja. Worked for me!

    Edit: actually did not.. was able to upload to itunesconnect but the the binary changed to invalid binary.
    Any suggestions?

  • megumimegumi Posts: 14Member, PRO

    Hi, I followed the steps recommended by ForumNinja but I'm still getting the same 'arm 64' error. I look forward to this issue being resolved soon.

  • BobDBobD Posts: 374Member, PRO

    I was also able to generate binary but it is rejected after uploading to iTunes Connect.

  • BobDBobD Posts: 374Member, PRO

    Dear developer,

    We have discovered one or more issues with your recent delivery for "Chi Chimes Timer". To process your delivery, the following issues must be corrected:

    Missing Info.plist value - A value for the Info.plist key 'CFBundleIconName' is missing in the bundle 'com.xxxxx.xxxxx'. Apps built with iOS 11 or later SDK must supply app icons in an asset catalog and must also provide a value for this Info.plist key. For more information see http://help.apple.com/xcode/mac/current/#/dev10510b1f7.

    Once these issues have been corrected, you can then redeliver the corrected binary.

    Regards,

    The App Store team

  • themysticgraphicthemysticgraphic Posts: 6Member, PRO
    edited November 29


    I have this issue too, and nothing has helped. I tired changing the minimum required OS to 8.0 and hard reset, and re-signed, and NOPE. Still have same issues. I know on Firefox, I couldn't even select the 7.0 and change it.

  • megumimegumi Posts: 14Member, PRO

    I submitted an app to iTunes without getting any errors. Thankyou very much all at Gamesalad for fixing this problem :smile: I love Gamesalad!

  • megumimegumi Posts: 14Member, PRO

    Well, everything was fine till I checked iTunesconnect and saw my App icon was the Gamesalad icon. I hope Gamesalad can also fix this error soon.

  • dapiondapion Posts: 316Member, PRO

    Just tried again to upload the ipa file.
    It worked, but the Background Activity still shows the ITMS-90503 error.
    Will test the app right through TestFlight.

  • kobayaashikobayaashi Posts: 138Member, PRO

    Have just submitted via iTunes Connect, with no probs apart from the icon issue. Much as I love the GS logo, I think I'll wait til this final issue is sorted before I submit for review! :smile:

  • manoolgamesmanoolgames Posts: 19Member, PRO

    I don't know if this is a related error but I just tried submitting an app and got the following:
    ERROR ITMS-90596: "Invalid Bundle. The asset catalog at 'Payload/analysis.app/assets.car' can't be read. Try rebuilding the app with a non-beta version of Xcode and submit it again."
    My Xcode version is 7.2.1, OS X Yosemite. I published my last game in September and everything was fine

  • megumimegumi Posts: 14Member, PRO

    Well everything looks good apart from the icon problem. @adent42 is working hard trying to fix it, so let's hope we can get this issue resolved soon.

  • megumimegumi Posts: 14Member, PRO

    The icon problem is fixed and everything is working beautifully again. Thanks Gamesalad.

  • dapiondapion Posts: 316Member, PRO

    Works by me too...
    Thanks GS!

  • -Timo--Timo- Posts: 2,309Member, PRO
    edited December 4

    ERROR ITMS-90596: "Invalid Bundle. The asset catalog at 'Payload/xxxxx.app/Assets.car' can't be read. Try rebuilding the app with a non-beta version of Xcode and submit it again."

    I am still getting this error. Any way to fix? @adent42 @ForumNinja

  • -Timo--Timo- Posts: 2,309Member, PRO

    @-Timo- said:

    ERROR ITMS-90596: "Invalid Bundle. The asset catalog at 'Payload/xxxxx.app/Assets.car' can't be read. Try rebuilding the app with a non-beta version of Xcode and submit it again."

    I am still getting this error. Any way to fix? @adent42 @ForumNinja

    /\

Sign In or Register to comment.