ERROR ITMS-90035 and ERROR ITMS-90179

eligameseligames Member, PRO Posts: 40
edited April 2018 in Working with GS (Mac)

I am trying to submit my ipa to the iTunes store but I keep getting

ERROR ITMS-90035: "Invalid Signature. Invalid resource directory (directory or signature have been modified). The file at path [Sugar] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose "Clean All" in Xcode, delete the "build" directory in the Finder, and rebuild your release target. For more information, please consult"


ERROR ITMS-90179: "Invalid Code Signing. The executable 'Payload/Sugar' must be signed with the certificate that is contained in the provisioning profile."

It was working just fine the day before and I do not know what happened. I tried resetting my provisional profiles and resigning the app but it still is not working. I am running on the newest version of game salad as well.


  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,866

    Please sign with the 1.25.91 update. Basically we had an extra flag on signing in 1.25.89 that breaks expectations on Application loader.

  • KAJAMstudiosKAJAMstudios Member, PRO Posts: 26

    @adent42 it's still not working for me even though i updated it to 1.25.91. I am on a MacBook, and it was working perfectly fine yesterday.

  • vafurlogivafurlogi Member, PRO Posts: 203
    edited May 2018

    I got this error (90035) and we were scratching our head for two days. We were updating three apps and only one got this error. Nothing had changed since the last update other than the game engine. What fixed it for us today was that the signed file contained a special character in the name "é" (not changed since 2014). We tried with both creator versions .91 and .92 but changing the name of the file seemed to do the trick. Might have been a fluke, don't know.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,866

    is the problem only on Build RC?

  • vafurlogivafurlogi Member, PRO Posts: 203

    @adent42 said:
    is the problem only on Build RC?

    My app was built with both .91 and .92 and got the 90035 error. I just now noticed the "Build RC" button under IOS universal now. Thought that was just for the Android version.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 1,866

    So if you didn't use the RC build, there shouldn't be a problem. The problem your describe should be fixed if you sign with 1.25.92. Sorry for all of the version weirdness, we're hoping to resolve it soon.

  • Titanical Tech ProductionTitanical Tech Production Member, PRO Posts: 35

    Make sure you click the Sign App button instead of the click here message in the publish.gamesalad portfolio.

  • ideonteamideonteam Member, PRO Posts: 1

    @vafurlogi I confirm, I had the same issue with the name. Once I modified the special characters, I was able to upload the project on the AppStore.

    Thank you.


Sign In or Register to comment.