AdMob Ads is not showing

Hi.

I've been working with GameSalad for over 8 years.

I've never had this problem before.

With the next publication of my application, AdMob (interstitial and banner) ads stopped showing.

The ad unit ID has been the same for 2 years. I have never changed it.

This time also.

I have tens of thousands of active devices on this application and I wanted to make a Christmas update.

I don't think I'm doing anything wrong. I've done this a hundred times.

Can anyone help me ?

Please.

Comments

  • hilmy31987hilmy31987 Member, PRO Posts: 7

    same thing has happened to me, after updating my apps no ads are working even after adding the Integer Attribute "privateAdsConsentForAds" and changing its value to 1. No answers, no solutions for me neither i am desperate

    https://hilmytejada.dev

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,187

    We just finished up work on MacOS Creator. PM me the publishing page to take a look.

  • gajaklukaszgajaklukasz Member, PRO Posts: 102

    I can't send you a message.

    I've been trying for the third day.

    Gateway timeout

    I try on Mac and Win PC publish my apk.

    I try AdMob and Chartboost and nothing.

    Both ad services do not display ads :-(

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,187
    edited December 2020

    @gajaklukasz i've gotten all the messages. This vanilla forums installation has a weird bug with sending messages where the request seems to timeout, but if you refresh your messages queue, you'll see the message has been sent.

    Everyone else:

    We found the issue with admob ads (and likely chartboost as well). We've pushed a fix.

    Basically the new RC has some new java classes required for ads that weren't required before. When making a build, we remove "unused" classes to make the APK smaller. In this case, we removed the required classes and that broke things.

    In our test system we had found a version of the issue: our "fix" for things worked in some configurations, but not in others.

    So no need for a new build release, we just had updated our publishing process.

    Please hit "Build RC" again and things should work fine!

  • gajaklukaszgajaklukasz Member, PRO Posts: 102

    Yes ! Yes ! Yeaah !

    I love You guys !!!!

    Merry Christmas and thanks for a good job 👍️

  • hilmy31987hilmy31987 Member, PRO Posts: 7

    Can I hit AWESOME more than once? =D

    https://hilmytejada.dev

Sign In or Register to comment.