apksigner problem

Hi, I have been trying to update my game after about a year since the last update and I've been having this problem since trying to sign the app. I have tried searching and trying different things to sign or fix the apksigner but with out any luck. please can anyone help? thanks, Dave.

Comments

  • ArmellineArmelline Member, PRO Posts: 5,050

    Did you click the "select" button and manually locate it, or is that just GS's attempt at finding it?

  • dcurren6dcurren6 Member, PRO Posts: 12

    This is gs trying to find it, I've clicked on select to manually find it and when I select the keystore which I usually use it still doesn't give a tick box.

    Ive tried to make a new keystore to see if that works but it says I've already made one.

  • dcurren6dcurren6 Member, PRO Posts: 12

    Im thinking to try and message google launch to see if they are able to fix it from there end. Ive updated all the programmes I need including android studio but it still didn't fix the problem and I'm a bit confused what to do.

  • ArmellineArmelline Member, PRO Posts: 5,050

    When I've signed apks it's showed the same red ! but when I click the "Select" button and locate the apksigner manually it works just fine.

  • bob loblawbob loblaw Member, PRO Posts: 688

    dave, i have the same thing, but i click select, manually follow the path/crumbs as shown in that box, and locate the folder of whatever the most recent build tools are (i think mine is 27 not 29, so maybe need to update it), and use the apksigner in there.

  • gingagaminggingagaming FREELANCE GS DEV Member Posts: 1,683

    The easiest solution for this is to create the path GS is looking for and store your zipalign and apksigner there. (just copy it) you dont need to mess about each time fixing the pah that never saves.

    Hopefully @adent42 will fix the path saving one day!

  • dcurren6dcurren6 Member, PRO Posts: 12

    Thanks for your comments. Ive tried selecting and using all different apksigners plus the main one I use to update my games but it still doesn't change to a tick. I spent the whole weekend trying to select different things and try different things from watching videos but still no luck. ive messaged google play to see if they can help but I will keep trying until they reply. thanks.

  • dcurren6dcurren6 Member, PRO Posts: 12

    Thanks for your help everyone. Ive just managed to fix the problem I just changed apksigner build 20.0.3 to 20.0.2 manually matching the same as the zipalign and it shown the tick and let me sign it. But I couldn't find it when trying to search it in the select option.

Sign In or Register to comment.