Apk wont install on phone

ZwireZwire Member, PRO Posts: 175

Hi all,

Im using a pc with windows 7 and generated an apk file, successfully signed it but when I try to install the apk on my phone it begins installing but when its almost done it says "app not installed" and the installation will be aborted.

I searched through the forums and people had this problem since 2013 but I couldn't find a solution for it.

Does anybody know how to solve this?

I tried JDK 1,7 and 1,6 after 1,8 and all three versions don't work.

@adent42 Any tips? I hope you have heard of this issue since its been around a long time.

Comments

  • ZwireZwire Member, PRO Posts: 175

    Has anybody here published with a pc and windows 7?

    Maybe its a windows 7 bug.

  • adriangomezadriangomez Member, PRO Posts: 255

    What is the error you are getting in the android console?

  • ZwireZwire Member, PRO Posts: 175

    I dont get any errors. Also not during generating and signing.

    The apk just quits installing and it says app not installed. See picture. "Niet" means not and "geinstalleerd" means installed.


  • adriangomezadriangomez Member, PRO Posts: 255

    All these steps you should find instructions on the web:

    1. Download and install Android Studio.
    2. Open up Android Studio. Click alt-6 to bring up Logcat. You might have to create a random project to get to the screen. Just click, click, click until you are on the main screen.
    3. Enable development mode on your test phone.
    4. Plugin the phone to your PC. Trust the computer on the dialog box that shows up and check-off always. So you don't have to do this ever again.
    5. Select your phone in the pull-down of logcat.
    6. Install your apk from the command line. On my machine: "C:\Users\me\AppData\Local\Android\Sdk\platform-tools>adb.exe install -r \Users\me\Desktop\chancleta-s.apk"
    7. Watch logcat for the error.

    Some errors I have seen:

    1. Failure [INSTALL_FAILED_ABORTED: User rejected permissions]. On some devices, you have to specifically allow the install.
    2. Bad URI: On some rooted phones the path that the version of the installer tries to install it onto a folder that it doesn't have permission to.
    3. Version downgrade: A app with the same id has a higher version than the version of the app you are trying to install.
    4. Different signing cert: A app with the same id as the one you trying to install already exists with a different signing cert.
    5. Incompatible binary: The device does not support the instruction set of the app. Usually happens when you try to install a typical android app on one of those old Intel chip devices.
    6. SDK version under device OS version: Happens when you select 21 as the minimal version in GameSalad but your phone is running an older version.

    These are just the ones I have encountered, I suspect there are more.

  • ZwireZwire Member, PRO Posts: 175

    You da man!

    Solved it. It was something stupid. There was an older version installed somewhere on my phone and thats why it didnt install.

    Thanks!

Sign In or Register to comment.