Mac .apps no longer work after downloading and unzipping?

LokitoesLokitoes Member, PRO Posts: 171

"Check with the developer to make sure [game name here] works with this version of macOS. You may need to reinstall the application. Be sure to install any available updates for the application and macOS. Click Report to see more detailed information and send a report to Apple."


Just this week I have been getting this message when trying to open my games as Mac .app files and it is super bad timing. I'm running Mac OS 10.13.6 (High Sierra) and GS 1.25.100 and have downloaded previous versions of these apps that have worked fine. I've also sent the files to other people and they can't get them to open either. I haven't done any Mac updates that would cause this.


Any clues as to how to fix this?

Comments

  • LokitoesLokitoes Member, PRO Posts: 171

    I've tried on a third computer now (since typing that last message whatever was happening with those files caused my 2019 macbook pro to die completely and now won't turn on), and the files unzip but open to only a black screen and every button your press makes a weird beep, and it is impossible to escape the file without restarting the computer. ??

  • LokitoesLokitoes Member, PRO Posts: 171

    Hey @adent42 I think the problem is with the GS servers as everything I've processed in the past couple of days (though I've only been doing .app files) opens as a black screen and makes a loud beep when any buttons are pressed (as mentioned above). But the gameproj file and it's preview work just fine, and .app processing worked fine for me last week. Would there be an ETA on when that might be resolved?

  • pinkio75pinkio75 Member, PRO Posts: 1,042
    edited April 2

    Recently Mac Apps have few issues like:

    -Joypad not working fine in Catalina (Creator and Apps; works fine just in Mojave)

    -Some of my game have issue when i switch in full screen (the touch command not working fine)

    -And i've see that the games works fine only for Catalina (someone not run in lower OSX versions)

    Anyway for your black screen error have you try to use build RC when compiled the game?

    @Adent could You try to fix these errors?

    Thanks in Advance.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,179

    @Lokitoes can you DM me the publishing link for the app you're having troubles with so I can debug?

    @pinkio75 we're testing a new release, so something should be out today. Joypad hasn't been addressed, I suspect it's something to do with MFI joypads support. I tested touch and it

  • LokitoesLokitoes Member, PRO Posts: 171

    Thanks guys things seem to be working better in the RC build and I'm just going to double check with my client that they're working on his end before celebrating too hard. Apologies if I came across as a bit, er, unstable earlier in this thread, I was having a complete panic attack over this yesterday and it didn't help that my computer decided to die and restore factory settings right in the middle of it. 😂😂

  • pinkio75pinkio75 Member, PRO Posts: 1,042
    edited April 3

    Thanks @adent42 but in the full screen mode of my letterbox version of my Mac App build with RC not working fine the touch i mean i need to press not in the center of the actor; (i send you a file in PM)

    This issue affect just the letterbox version in full screen mode.

  • pinkio75pinkio75 Member, PRO Posts: 1,042
    edited April 4

    Update for Mac Apps build with the latest RC:

    • Touch works in full screen in letterbox.
    • Games runs fine on lower OSX versions.
    • Joypad not works on Catalina; works on lower OSX versions.

    Thanks to @adent42

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,179

    @Lokitoes @pinkio75 please test the new RC. I think i figured out @Lokitoes problem as we were using libraries compiled for macOS 11 by mistake. I can't test it it yet (I need to dig out an older machine).

    @pinkio75 the new build should work fine if you start in window and change to full screen mode. It's broken if you start in full screen mode, so I'm looking into that.

Sign In or Register to comment.