Mac review feedback: Game doesn't start, only gray screen?!

My games were in review and I got now the feedback, that they not run. After the start nothing happens than a gray screen appear.

I've tested the game on my old mac (Intel) and it worked without problems.

Maybe, thats because I made them with an old Mac Mini (2012) and they were not 64Bit only?

I am not sure. In a few weeks I can test with a new MacMini M1, but for now I didn't have an answer.


  • adriangomezadriangomez Member, PRO Posts: 412

    What is the name of your game? I'll try it on my machine.

  • MarcoColMarcoCol Member, PRO Posts: 279


    currently it was not approved by Apple.

    I have had the chance to test it on an M1 Mac Mini and I see after the start a gray screen, and nothing seems to happen. But I can click around and it seems that the game runs, but behind a gray screen. I can't get out of this screen. This seems to be only on new Macs, because when I test it on the old Mac Mini (Intel from 2012), it runs without problems.

    I thought it might be happen because of the building with the old Intel-Mac, but building process will be done by GameSalad online if I am right. But I can test building with the new Mac Mini M1 in a few weeks and check again, if there are no other possible mistakes I've done...

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,961

    Thanks for checking this out. We haven't tested on an M1 yet, so I guess I'll be breaking an M1 laptop out to test with.

  • MarcoColMarcoCol Member, PRO Posts: 279

    Oh, ok. Please test Mac apps, which were finalized and uploaded with Intel Macs.

    I think it has nothing to to with the build in general, because it will be online on your servers, right? But any problim might be there with the Mac Apps...

  • MarcoColMarcoCol Member, PRO Posts: 279

    Any news on that?

    I would like to update the apps for Mac soon.

    Also what about the 64Bit-Only for Macs? I think since a few years apps are only allowed as 64Bit-Only apps. This will be done when build with GameSalad, right?

    The last time I updated the app, I think it was 32- and 64Bit and that's why they throw it out of the App Store...

  • MarcoColMarcoCol Member, PRO Posts: 279

    Happy new Year!

    Are there any news regarding that? The current state is, that I can't provide an update, because of the gray screen...

  • MarcoColMarcoCol Member, PRO Posts: 279

    Hi again,

    does anyone other have this problem?

    I made a new version of my game for Mac OS. It runs without problems on an Intel Mac from 2012.

    But on a new M1 Mac, it crashes.

    Might it be different, when I build it with the M1 mac? I think no, because building will be done by GameSalad on their servers, right?

    I mean, there should be a lot of, who have this problems with new Macs?

    Might it be a 64-Bit-problem? Or an Intel-/M1-CPU-problem?

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,961

    It's likely an Intel / M1 CPU problem. Which version are you running? Have you tried the 105 beta?

  • ArmellineArmelline Member, PRO Posts: 5,304

    I assume he's talking about a macOS game generated through publishing, so engine rather than Creator.

    Generated games work fine for me on Intel (no M for me yet 😥) but weird things happen with the loading screen. Will need to test more though to give any useful infomation.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,961

    @Armelline we've been working on the issue with him. The issue is not M1 per se but recent macOS versions. Basically they changed some stuff under the hood with how they handle full screen windows, breaking some of our code. We pushed an update to the RC to handle the issue, but now older OSes are seeing issues. We're not actively working on the issue today, but we'll be taking a look at it again this week.

    For now your choices are publishing with Build and limiting your games to macOS 12 or lower (we think?)

    Or Build RC and setting your app to macOS 13 or greater.

Sign In or Register to comment.