GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Gamesalad on a mac mini

THRSTNTHRSTN Posts: 178Member
edited November -1 in Tech Support
Hi everyone first of let me say everyone on these forums have been amazingly helpful, especially tshirtbooth, Jameszepplin and firemaplegames you guys have taught me sooooo much thanks. Im completely new to macs (always ben a PC guy) so when a friend offered me his mac mini to try my hand a gamesalad i was all for it.Now i have purchased my membership in gamesalad and with apple and over the last 4 months have made a game im really proud of and am ready to test it on my device's. but when i try to download the latest version of xcode im unable to run it on my mini. I have version 3.1.1 on here now but i know i need to update because of os4. The OS im running is MAC OS X 10.5.8 and im trying to update that but everything i try tells my its "This software is not supported on your system." i cant afford to go buy a mac book i need to work with what i have.any suggestions would be very welcomed.

thanks

THRSTN

Comments

  • THRSTNTHRSTN Posts: 178Member
    THRSTN said:
    Hi everyone first of let me say everyone on these forums have been amazingly helpful, especially tshirtbooth, Jameszepplin and firemaplegames you guys have taught me sooooo much thanks. Im completely new to macs (always been a PC guy) so when a friend offered me his mac mini to try my hand a gamesalad i was all for it.Now i have purchased my membership in gamesalad and with apple and over the last 4 months have made a game im really proud of and am ready to test it on my device's. but when i try to download the latest version of xcode im unable to run it on my mini. I have version 3.1.1 on here now but i know i need to update because of os4. The OS im running is MAC OS X 10.5.8 and im trying to update that but everything i try tells my its "This software is not supported on your system." i cant afford to go buy a mac book i need to work with what i have.any suggestions would be very welcomed.

    thanks

    THRSTN

  • TymeMasterTymeMaster Posts: 527Member
    You need to install Snow Leopard on the Mac Mini.

    Newer versions (required) of XCode do not support anything lower than 10.6 (Snow Leopard). Then it will work fine.
  • PhoticsPhotics Posts: 4,172Member
    Did you look at the requirements?

    http://gamesalad.com/products/creator

    An Intel Mac is required... Snow Leopard is only required for iPad and iOS 4 publishing.
  • chosenonestudioschosenonestudios Posts: 1,714Member
    You need to upgrade to Snow Leopard.

    Edit: Thats why you don't open up a page type the answer and then submit the post 20 minutes later.

    Also, no need for spam.
  • quantumsheepquantumsheep Posts: 8,188Member
    My colleague has my old Mac Mini, and is able to run GameSalad just fine without Snow Leopard.

    He doesn't use the GS Viewer at all though, and as others have said, you may need Snow Leopard to access that feature (in conjunction with the Apple SDK).

    Snow leopard is relatively cheap, and it's worth the asking price just for the Gigs it gave back to me on installation! :D

    Good luck,

    QS :D

    Dr. Sam Beckett never returned home...
    Twitter: https://twitter.com/Quantum_Sheep
    Web: http://www.quantum-sheep.com

  • quantumsheepquantumsheep Posts: 8,188Member
    tshirtbooth said:
    QS should you not be at the meet up right now?

    I went, I saw, I drank some beers, I came back :D

    Dr. Sam Beckett never returned home...
    Twitter: https://twitter.com/Quantum_Sheep
    Web: http://www.quantum-sheep.com

  • chosenonestudioschosenonestudios Posts: 1,714Member
    quantumsheep said:
    I went, I saw, I drank some beers, I came back :D

    Welcome back from your great adventure!
  • POLYGAMePOLYGAMe Posts: 3,470Member
    THRSTN said:
    Hi everyone first of let me say everyone on these forums have been amazingly helpful, especially tshirtbooth, Jameszepplin and firemaplegames you guys have taught me sooooo much thanks. Im completely new to macs (always ben a PC guy) so when a friend offered me his mac mini to try my hand a gamesalad i was all for it.Now i have purchased my membership in gamesalad and with apple and over the last 4 months have made a game im really proud of and am ready to test it on my device's. but when i try to download the latest version of xcode im unable to run it on my mini. I have version 3.1.1 on here now but i know i need to update because of os4. The OS im running is MAC OS X 10.5.8 and im trying to update that but everything i try tells my its "This software is not supported on your system." i cant afford to go buy a mac book i need to work with what i have.any suggestions would be very welcomed.

    thanks

    THRSTN

    Download the update from Apple without using the Mac's "Software Update" feature. I have had the same problem with updates. Just download the .dmg and install as any other app. Should do the trick ;-)
  • TymeMasterTymeMaster Posts: 527Member
    quantumsheep said:
    My colleague has my old Mac Mini, and is able to run GameSalad just fine without Snow Leopard.

    He doesn't use the GS Viewer at all though, and as others have said, you may need Snow Leopard to access that feature (in conjunction with the Apple SDK).

    Snow leopard is relatively cheap, and it's worth the asking price just for the Gigs it gave back to me on installation! :D

    Good luck,

    QS :D

    If you want to target iOS4 (as the OP said I think), you need Snow Leopard. Matter of fact Apple doesn't provide XCode for anything other than Snow Leopard at this time, and you need the latest SDK to support 4
  • THRSTNTHRSTN Posts: 178Member
    Thanks for the suggestions. I bought snow leopard but now it's throwing an error at install and I can't get my project back. Not freaking out yet cause I have backups but I don't want to restore if I don't have to.
  • sad6sad6 Posts: 3Member
    I had to switch to GM cuz of that :( Well, this is my last time to ever be on this site ;( ;( ;( bye!
  • sad6sad6 Posts: 3Member
    Maby if i get a new mac I'll come back ;)
  • jonmulcahyjonmulcahy Posts: 10,384Member, Sous Chef, PRO
    just want to make sure this is an intel mac mini and not a g4 mac mini
  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    Ah yet another old post dug up for snow apparent reason.
    I would hope that in the last 4 months THRSTN was able to find someone maybe the place that sold him snow leopard to help him out. :)

    It's not my fault I never learned to take responsibility for anything. ;)

  • jonmulcahyjonmulcahy Posts: 10,384Member, Sous Chef, PRO
    geez i didn't even notice the time frame. shame on me! :)

    I'm closing this down.
This discussion has been closed.