When I place images they scale up. Why?

Fodder76Fodder76 Member Posts: 154
edited November -1 in Working with GS (Mac)
Hi there,

Very new to Gamesalad, but right out of the gate I'm having a frustrating but probably very simple issue.

I'm trying to develop at the iPhone 4 resolution of 960 x 640. I've made my images that size, and as I'm dragging them over to drop them in the scene, they appear to fit perfectly within the border, but as soon as I release the mouse button, they scale up to many times their original size.

What am I doing wrong? Thanks!

Comments

  • JohnPapiomitisJohnPapiomitis Member Posts: 6,256
    are you dragging the image into the actor section to make a new actor, then dragging the actor on screen?
  • gyroscopegyroscope I am here.Member, Sous Chef, PRO Posts: 6,577
    Hi Fodder76, I suspect it's because you haven't checked Enable Resolution Independence in the Project Editor.

    ""You are in a maze of twisty passages, all alike." - Zork        temp domain http://spidergriffin.wix.com/alphaghostapps

  • Fodder76Fodder76 Member Posts: 154
    John,

    Yes, I am doing that.

    gyro. I did check that box.

    So from what I understand the camera size defaults to 480 by 320. When making a game that supports the retina display, do I need to increase the camera size to 960 x 640?

    That would make sense. I am just confused as to why the images I place appear to be the correct size until I let go of the mouse button.

    Thanks for your help guys.
  • tenrdrmertenrdrmer Member, Sous Chef, Senior Sous-Chef Posts: 9,934
    no need to change the camera. It will cause you problems if you made actors before check RI. (at least I have experienced issues that way. )

    Double check that RI is checked and then open existing actors and drop the new art in there. other wise you will likely have to reopen and resize them back down. Any new actors after RI is checked should scale down to the correct size.
  • Fodder76Fodder76 Member Posts: 154
    Got it, thanks very much all!
Sign In or Register to comment.