Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fire Button?

blastfactorblastfactor Posts: 72Member
edited November -1 in Miscellaneous
i have been looking at other posts and stuff and they dont seem to help me...
i try to make a fire button, i place it on the canvass, i make sure that if tap then shoot = true, then if shoot = true then spawn actor blah blah blah
well.. it still aint workin for me, anyone know why?


  • blastfactorblastfactor Posts: 72Member
    the bullet isnt spawning at all, when i had it so that it would go with pressing spacebar it worked.. but now its hard to do anything, whenever i click something, gamesalad freezes and i cant do anything
  • blastfactorblastfactor Posts: 72Member
    i know there have been posts about this before, but like 6 months ago... has there been a patch/update to fix the slowing down? or something to do to fix it myself?
  • blastfactorblastfactor Posts: 72Member
    i know that haha, im just wondering if there is a fix to that.. because i close gamesalad and open it back up and it just K.E.E.P.S. .F.R.E.E.Z.I.N.G! D: its sooooo anoying! haha, anyways, i will try to fix the rule
  • blastfactorblastfactor Posts: 72Member
    k so in my "fire button" i have

    ~~When Actor recieves action/ touch /inside

    ~~When Actor recieves action/ touch /pressed

    ~~When blah blah mouse button clicked

    -change attribute game.Shoot to true

    -when actor recieves action touch is released

    -game.Shoot = False


    in my Main Character, this is what is in relation to the problem

    -if game.Shoot = true

    -play sound

    -spawn actor (bullet)
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    sounds like you have all those touch rules in the same rule, and its when all conditions are valid. So unless you do all that at the same time it wont respond. Change it to when touch is pressed only and see waht happens
  • blastfactorblastfactor Posts: 72Member
    i just tried wat you said john... it didnt seem to change anything, maybee is it because im on a computer and it doesnt recognise touch? haha
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    No it registerss it with the mouse. Did you double click and unlock the actor in the scene, and are your rules in the main actor in the actor pane to the left?
  • blastfactorblastfactor Posts: 72Member
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    thats why. When you double clicked the actor in the scene you unlocked it. Put the rules in the actor in the mane pain then drag into the scene.

    and only have when touch is pressed
  • blastfactorblastfactor Posts: 72Member
    whenever i try to open it in the main pain, it freezes
  • blastfactorblastfactor Posts: 72Member
    its a 17" macbook pro that i got about 2 months ago.. it was all working fine untill about an hour ago
  • calvin9403calvin9403 Posts: 3,190Member
    Alright, I did not see this post till now.
    It seems that your mac has problems
    I will send you a mail and see if you got it
This discussion has been closed.