GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Publishing Major Headache

sj.iphonesj.iphone Posts: 28Member
Issue: Publishing

Background:
1) Using Creator .92 I finished my game
2) Could not publish.
-Got the message “Account does not have right permissions”.
-Also game was not in portfolio.

Steps taken:
1) Installed Xcode 4
2) Installed Viewer .92
3) Installed Safari plug in .92
4) Removed and reinstalled Creator .92

Results:
1) Game was in portfolio
2) Did not get message about permissions
3) Publishing Manager contacted Game Salad
4) Blue white horizontal loading indicator kept rolling for 30 minutes
5) I cancelled
6) Tried again from portfolio and got message “game did not load completely last time try publishing directly from creator.”
7) Closed and reopened GC Creator, published directly from game. Loading indicator rolled for 3 hrs.

Next day
1) started publishing at 6 AM – at 6 PM loading indicator was still running.

Help!!!! Please.

Comments

  • jtadeojtadeo Posts: 92Member, PRO
    re:"Got the message “Account does not have right permissions”."

    I've had that happen to me a couple of times. If you are working off a service like Dropbox then you may want to copy your file from Dropbox over to your local drive. As well, closing out your apps and restarting may help as well.

    btw, how many MB is your game and what is the speed of your connection? Those may affect it as the publishing process appears to be dependant on the server.

    And just in case, if you haven't already, contact support. There is a PRO support plan and you may get the answer directly from them.
  • butterbeanbutterbean Posts: 4,315Member, PRO
    Hey: I've gotten that error message before:

    With the "you do not have correct permissions"

    Try logging out, THEN hit the publish button, and log in and it should work...

    Regarding the other stuff, could be server issues... How large is your game?

    Make sure you right click on your game project, and remove all screenshots before publishing.. it could be timing out b/c of that...
  • sj.iphonesj.iphone Posts: 28Member
    Thanks to both you guys for your answers. My game is 4.3Mb and I have high speed internet access. I'll try deleting all screenshots and trying again.
  • sj.iphonesj.iphone Posts: 28Member
    Hey butterbean, thx for your suggestion but I tried deleting all screenshots and couldn't get past the 'add screenshots' phase. I tried with only one image (primary), but still couldn't upload. I also put in a support ticket request an am awaiting a response.
  • butterbeanbutterbean Posts: 4,315Member, PRO
    Hey there!

    You can delete the screenshots from your project before publishing. Right click on your project and take all the screenshots out.

    Now when you're publishing, when you get to the part where it says add screenshots, that won't affect your file size, just add at least one screenshot or more to the image wells to move one and you're good :)
  • jacubancutiejacubancutie Posts: 1Member
    Greetings everyone!

    What was the outcome of this?

    In addition, has anyone published a GS game in XCode 4 yet?

    Do tell. Have a good day!
This discussion has been closed.