GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Trouble with viewer, provisioning profile expired

butterbeanbutterbean Posts: 4,315Member, PRO
edited November -1 in Working with GS (Mac)
So I'm having trouble with updating the viewer, it says the provisioning profile has expired in xcode, but the icon appears on my iphone

When I press the icon to open the viewer, it says the provisioning profile has expired... I updated it and installed it but it still won't let me open it!

Anyone have any tips? Really appreciate it!

Comments

  • JGary321JGary321 Posts: 1,246Member
    Yup log into your Apple Development account... Go to provisioning.. hit renew under for your viewer app.

    Then re-download the file. Drag to itunes. Or open xcode & goto organizer & drag to there..

    I just had to redo mine as well.

    EDIT: You may have to remove viewer off the iphone & reload it. I'm not sure. I personally had to. But I was having other issues.
  • butterbeanbutterbean Posts: 4,315Member, PRO
    Yea I renewed the provisioning profile and checked it through xcode and it says it expires march 2010, and my device is related to that profile

    Everytime I try to reload the viewer through xcode, it says:

    Error from Debugger: Error launching remote program: security policy error

    And when I try to click on the gamesalad app viewer on my iphone it says:
    The application Gamesalad viewer could not be opened because the provisioning profile has expired

    I even shut down and restarted the iphone, and even created a different provisioning profile and still got the same error....
  • JGary321JGary321 Posts: 1,246Member
    Try removing the old viewer off your iPhone. Then remove the old provisioning profile if it's still there. You can do this through the iPhone. Go under settings, general, then profiles. Then try to just re-build the viewer like you would after a viewer update. At least try this. I was having some issues & this is what I did. HOPEFULLY this works for you.
  • butterbeanbutterbean Posts: 4,315Member, PRO
    Thanks, codemonkey told me to delete all the profiles on there, and load the new one, it must have been drawing from the old provisioning profile, so that worked!
This discussion has been closed.