GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Why does my game not work?

SynstealSynsteal Posts: 32Member
edited November -1 in Tech Support
It doesn't work using gamesalad viewer and when i uploaded to test it directly the gamesalad logo comes up then blank white screen and crashes and returns to the ipod menu. Why does my game not work in the slightest?

Comments

  • SynstealSynsteal Posts: 32Member
    The game works well enough in the preview. But just crashes when i use the gamesalad viewer or upload through itunes. I haven't copy and pasted any of it from another game and i don't see any rules that have had an attribute deleted.
  • SynstealSynsteal Posts: 32Member
    File sent
  • LumpAppsLumpApps Posts: 2,869Member
    Just a wild guess.
    Check if your images are all PNG's, I had this once and found I accidentally dropped a Photoshop document in the images, it worked on the mac but crashed on the iPhone.

    (Right click your project -> show package contents -> folder images)
  • SynstealSynsteal Posts: 32Member
    ok now it sent
  • SynstealSynsteal Posts: 32Member
    im pretty sure they are all png
  • SynstealSynsteal Posts: 32Member
    oops
  • SynstealSynsteal Posts: 32Member
    Should be sending any second my internet is slow today
  • SynstealSynsteal Posts: 32Member
    ah DPi?
  • SynstealSynsteal Posts: 32Member
    how do i fix that? im not exactly photoshop savvy and i used gimp to create all the images. However if this fixes it you are the best.
  • SynstealSynsteal Posts: 32Member
    yeah i liked my animation but I'll just have the logo fade in then out instead and get rid of the images. Thanks for the help.

    Though what is the actor limit for a single scene? I fear my title animation might cause problems.
  • YodapolloYodapollo Posts: 447Inactive
    @Synsteal

    It looks like the issue has been traced to images in the project. Any objection to me marking this 'resolved'?

    --Yodapollo
  • IncrediboIncredibo Posts: 274Member
    Im having the same problem now that T-shirt booth said, it was the image dpi. I went to take a look and all of mine are like 72.009 to ): But I guess ill have to resize one-by-one
  • SynstealSynsteal Posts: 32Member
    @Yodapollo not at all
    i just have to go through my images and correct them now too
  • YodapolloYodapollo Posts: 447Inactive
    Yeah, it's problem that even I've come into with Photoshop. For some reason, image editing programs sometimes set the default resolution to 72.00009 dpi rather than 72 dpi.

    The bad news is that it's a pain to correct. The good news is, it's such a pain that you'll always check the dpi before finalizing any new art.

    --Yodapollo
  • IncrediboIncredibo Posts: 274Member
    Actually another best answer.(: if you're USING PHOTOSHOP
    1.) GATHER ALL IMAGES AND PUT IN A FILE
    2.) OPEN PHOTOSHO FILE>PROCESS MULTIPLE FILES
    3.) ONCE TAB OPENS CLICK THE FILE IN WHICH ALL IMAGES ARE STORED
    4.) CLICK RESIZE IMAGES BUT ONLY CHANGE THE DPI TO 72 & LEAVE THE OTHER SPOTS BLANK
    5.) GICE IT A COUPLE MINUTES TO PROCESS & DONE.(:
  • SynstealSynsteal Posts: 32Member
    Ok I went through all my images and changed the resolution to 72.I also removed the opening animation of 170+ images. My game still will not work on my device. I even removed all the images from the the project to try it, but it still does not work. What else is preventing it from working?
This discussion has been closed.