GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Scrollable issues?

mrbrandbartmrbrandbart Posts: 9Member
edited November -1 in Working with GS (Mac)
Hi everyone,

I just followed Tshirtbooth's tutorial on multiscreen menus () however, any layer that I apply "scrollable" to won't scroll. I've startet the project all over 4 times now, and followed the tutorial everytime, even stopping and scrolling back just to make sure I've done everything entirely as Tshirtbooth describes, however with the same result.

Is this a bug in the latest Gamesalad version, or does some wise guy wish to help me :) I'm doing a game for my exams, got 2 weeks left, and im currently missing my menu.

Thanks in advance

Comments

  • mrbrandbartmrbrandbart Posts: 9Member
    Hmm, for some reason it seems the link got converted to a youtube video, and removed half my text, so here it goes again without the link :)

    Hi everyone,

    I just followed Tshirtbooth's tutorial on multiscreen menus however, any layer that I apply "scrollable" to won't scroll. I've startet the project all over 4 times now, and followed the tutorial everytime, even stopping and scrolling back just to make sure I've done everything entirely as Tshirtbooth describes, however with the same result.

    Is this a bug in the latest Gamesalad version, or does some wise guy wish to help me :) I'm doing a game for my exams, got 2 weeks left, and im currently missing my menu.

    Thanks in advance
  • mrbrandbartmrbrandbart Posts: 9Member
    It seems to me that its the "Control Camera" attribute that doesnt work. Even if I remove it from the "Cam" actor, and applies it to the drag actor it won't work.
  • mrbrandbartmrbrandbart Posts: 9Member
    Just to clear up:

    I've got the following layers

    Levels (scrollable)
    -LevelActor
    -LevelActor
    -Cam

    Drag (non-scrollable)
    -DragActor

    Background (non-scrollable)
    - Background

    Cam actor has "Control Camera" attribute. I have not turned DragActor and Cam invisible, so I can see that their both moving when I use the mouse to test, the camera window just doesnt follow Cam. I have narrowed the Cam window down to minimum so the camera should move whenever Cam actor does, but it doesnt.
This discussion has been closed.