GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

No more music

68kStudios68kStudios Posts: 219Member
edited November -1 in Tech Support
Hi,

with version 0.9.6 music no longer works when I try game on my ipod or other device.
Music works only in the first scene of the game. In the preview mode on mac, music works fine in every scenes, but when I try my app on any device, only sound effects works.

any idea?

thanks

Comments

  • steeler0038steeler0038 Posts: 153Member
    dude, i have this same problem! I asked this same question on the forum the other day, and everybody told me i was testing wrong. But this problem is very frustrating because I have a major update for my game, but I can't get the music to work!!! this has to be some sort of bug...
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    hmmm havent had this problem. You can send the project in a bug report to gamesalad. Also if you would like you can send me the project and ill run it on my viewer and see if it works for me

    cheers
  • GamersRejoiceGamersRejoice Posts: 817Member
    Yes send in for a bug report. There is a bug that drops the music volume down for an undetermined reason. The work around is to add change attributes to music volume 1. Place them where your play music behaviors are. This fixed it for me. The other problem is if you quit out of your app and re-open it the music is gone too (this only shows itself on the device.) So I guess for now you could add if touch equals 0 change music volume to 1.
  • 68kStudios68kStudios Posts: 219Member
    thank you, changing attribute to music volume works fine ;)
  • SyfluxSyflux Posts: 22Member
    I am having this problem as well. My music drops in a certain scene when I create a development build. I even tested my game with an older save that I knew worked 100% with the music and it still dropped it. Must be the latest patch.
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    @ Gamers Rejoice didn't know about the bug or that fix thanks for sharing!

    @Sylfux have you tried what gamers rejoice posted?
  • SyfluxSyflux Posts: 22Member
    @john

    I just tried GamersRejoice's fix and it seems to be working fine now.
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    glad to hear that :)
  • 11clock11clock Posts: 450Member
    I don't have this problem. Seems like I don't get most of the bugs that people have been complaining about.

    EDIT: Oh wait, didn't realize that 0.9.6 has been released. I need to update GameSalad more often.
  • epsilonstudiosepsilonstudios Posts: 40Member
    I'm having this same exact problem, I'm glad I checked the build on my device before updating my game. Thanks GamersRejoice for the work around.
  • GamersRejoiceGamersRejoice Posts: 817Member
    Glad I could help. :)
  • micksolomicksolo Posts: 264Member
    I'm having a similar problem.

    Menu Music works fine, go into first level and the success music doesn't play. I debugged the music volume to see if it was being changed to 0 but its always on 1.

    However when I pause the game, and go back to the level the music starts working again.
This discussion has been closed.