GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Crashing on startup :(

live_2_winlive_2_win Posts: 10Member
edited November -1 in Tech Support
Hey all!

I recently come across this when I updated to 0.9.5 (although that may not be the cause), every time I compiled in on my iphone in the viewer, it quits right after it loaded (but it only loads for around half a second). Keep in mind that it runs perfectly on the in-app mac previewer. Thinking it might be referencing an actor/attribute that isn't there or something of that nature, i deleted all scenes, actors, attributes AND images, then made a new blank scene and compiled in the viewer - still crashed. I don't know what to do, I'm a sad panda:(

Thanks in advance for any help.

Comments

  • live_2_winlive_2_win Posts: 10Member
    Any help at all?
  • live_2_winlive_2_win Posts: 10Member
    I only have a couple as it's a menu, and even when I made a new blank initial scene it still crashed so i don' think thats the issue.
  • quantumsheepquantumsheep Posts: 8,188Member
    Simple thing you've probably already tried - clear the 'recent games' in your viewer, make sure you stop the viewer properly (as in it's not in the list when multi-tasking) then switch the phone off and on.

    Might work...

    QS :)

    Dr. Sam Beckett never returned home...
    Twitter: https://twitter.com/Quantum_Sheep
    Web: http://www.quantum-sheep.com

  • live_2_winlive_2_win Posts: 10Member
    No sorry I've already tried all of that and reinstalled the viewer on my device :(
  • jonmulcahyjonmulcahy Posts: 10,380Member, Sous Chef
  • live_2_winlive_2_win Posts: 10Member
    They're all at 0 because it crashes before the game starts, you're talking about the fps and memory usage right?
  • live_2_winlive_2_win Posts: 10Member
    Yes as I've said I have already reinstalled the viewer, I don't know what else to do.
  • LumpAppsLumpApps Posts: 2,868Member
    Have you tried a new project?

    Make a new one with nothing in it and if that works try a new one with an actor and some rules.
    If that works there is probably something wrong with your project not the viewer.

    Always exclude stuff when debugging. Never guess and just start reinstalling stuff, that just takes a lot of time and gets you nowhere in most cases. Unless you feel lucky ;)
  • live_2_winlive_2_win Posts: 10Member
    Yep I've just recently done that, and it works, so I guess the problem lies in my project. I'm still stumped as to what to do, as I've already deleted everything in my project, and it wouldn't work, so it mustn't be the code. Also remember that it works when testing on the previewer on my mac.
This discussion has been closed.