GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Application failed codesign verification.......Please Help!

WGSgamesWGSgames Posts: 22Member
When trying to upload my game through application loader im getting this error "Application failed codesign verification. The signature was invalid, or it was not signed with an Apple submission certificate.

I've tried everything and I can't get it to work. Ive tried different things on the forum. I've even went through and deleted all of my certificates and created new ones and it still doesn't work. I don't know what else to do. Can somebody please help me?

Comments

  • ShineyGamesShineyGames Posts: 157Member
    Are you using the new beta xcode? For ios5 Cos it does not work
    Need to downgrade or get a copy of the old application loader
  • WGSgamesWGSgames Posts: 22Member
    I downloaded the new Xcode 4.2 after I got an error in the application loader saying I needed to download the newest Xcode. So then after I downloaded it I started getting the code sign error message. Do you know how I can get ahold of a copy of the old application loader?
  • SlickZeroSlickZero Houston, TexasPosts: 2,870Member, Sous Chef

    I have no friends. I'm a loser that makes video games all day. Will you be my friend?

  • Macca_McGillMacca_McGill Posts: 108Member, PRO
    WGS games i think thats the problem im having. When i try building my game in xcode to run on my device i get a codesigning error. When i upgraded xcode and gs viewer my bundle identifier had changed back to gendaigames one, so i changed that then started getting the codesign error instead! Ill try reverting back to the old one too :)

    Do i need to delete xcode off my machine then download the older one?
  • SlickZeroSlickZero Houston, TexasPosts: 2,870Member, Sous Chef
    You just need the older version of Application loader. Click that link above and you can get a working version. That's the same one I'm using, and can I confirm it works.

    I have no friends. I'm a loser that makes video games all day. Will you be my friend?

  • Macca_McGillMacca_McGill Posts: 108Member, PRO
    do i need to un-install the previous version? or do i just drag the xcode folder into where my newer version is, so it overwrites it?
  • WGSgamesWGSgames Posts: 22Member
    I downloaded the old version of application loader and I'm still getting the same codesign error. I don't know what else to do. This is an update to an old game so I don't know if that has something to do with it.

    JumpBox I think we're having the exact same problem. I downloaded the new xcode and had to change the bundle identifier as well.
  • Macca_McGillMacca_McGill Posts: 108Member, PRO
    I think i updated xcode and ios on my phone, then i updated gs, then it said my gs viewer needed updating so did that. Then i started having problems. No idea other than delete xcode n try again? Maybe delete the provisioning stuff n try again unless sum1 knows a fix?
  • WGSgamesWGSgames Posts: 22Member
    I went through and deleted all of my certificates and provisioning profiles again and started over. This time when I added my new provisioning profile into xcode it gave me this message in yellow "Xcode could not find a valid private-key/certificate pair for this profile in your keychain."

    I just went through and created all new certificates so I don't know why its giving me this message. Has anybody had this problem?
  • GLGAMESGLGAMES SingaporePosts: 988Member
    did u mix up the development key and distribution key when compiling within GS?
    Use distri key if uploading.
  • SlickZeroSlickZero Houston, TexasPosts: 2,870Member, Sous Chef
    Yeah, that usually means you are using the wrong profile. It's easy to get mixed up, and it usually comes down to a wrong profile being used when submitting.

    I have no friends. I'm a loser that makes video games all day. Will you be my friend?

  • WGSgamesWGSgames Posts: 22Member
    My problems keep getting worse. Now Im getting a code sign error when I try to publish through game salad. I've switched profiles, downloaded the old x code and app loader, made new certificates and still no luck. Ive published 3 games and never had this problem before. I think I messed something up in keychain access when I deleted all my certificates.

    The only other thing i can think of is to back up my files and then just restore factory settings on my computer. Then I guess I'll just start from scratch.
  • DaibusshiDaibusshi Posts: 47Member
    WGSGames, I have the identical problem... Started with an Apple rejection, and then everything APPEARS clean & easy on my computer's keychain & online dev profile after multiple removes, revokes and recreated certificates, recreated Dev & Dist provisions.. I have followed the TSB vids & GS tutorial letter-for-letter time and again, and I keep getting GS Code Sign failed because make sure certs, provs & WWDR are installed. I found this thread:

    http://gamesalad.com/forums/topic.php?id=25964#post-10296

    It *MIGHT* help. I guess I need to take a closer look at Xcode, but I doubt it'll do anything for me. I'm going to do a little more troubleshooting tonight if I find the time. I'm hoping it's an issue that is resolvable on GS's end, because I do have the proper certs & provs installed, but I am just about out of options and nearly ready to throw my hands up in the air and give on my dream of publishing my first game. Congrats on your first three, though! :-D If you find a solution, PLEASE PLEASE PLEASE let me know what you did right.
  • DaibusshiDaibusshi Posts: 47Member
    Hey. It worked. App uploaded to iTunes and waiting for approval!

    In a nutshell, here's what I did that I think helped:

    Days ago, after revoking and removing everything (for the 94th time) in sight from both my Provisioning Portal and Keychain Access' "My Certificates," I created yet ANOTHER unique App ID, and all-new pairs of Dev & Dist Certs and Provs on the portal. Installed them all on my computer & iTunes... ONCE.

    Now I don't know if this is a GS thing or an OSX thing, but even though I did everything very methodically and only once, I noticed that I still had multiples and/or duplicates of some Dev & Dist Certs showing up in my Keychain Access. I deleted all except the most recent Developer and most recent Distributor, according to expiration date.

    Published again to GS with the SAME Distributor Cert I'd been trying & failing for days, feeling like I was wasting my time. Bam! It worked!!!!

    The thing that kills me is that the Dev & Dist I finally successfully used in my keychain HAD ALREADY BEEN THERE FOR DAYS, properly installed and everything. What I had to do was delete the unused/older multiples & duplicates. And, for me, this worked. But holy cow, it should NOT have been that difficult to troubleshoot....
  • WGSgamesWGSgames Posts: 22Member
    After a week i finally got it to work. I restored the Original settings on my computer and deleted everything off of it. I then redownloaded Xcode. I then made new certificates and provisioning profiles and it worked. Who knows what went wrong before.
  • Fredrik BixoFredrik Bixo Posts: 239Member
    I'm on the last step to submit it to apple and i have exactly the same problem as WGSgames and daibusshi. did you have osx lion installed? and what version did you have of Xcode application loader and game salad.in the keychain did you have it on system or the loggin? and do you need to pair your key to iPhone distribution ? is so frustrating becous I'm on the last step!
    so please help :) :( // Fredrik,14 year, Sweden
  • Fredrik BixoFredrik Bixo Posts: 239Member
    edit:I have osx lion installed,gamesalad 9.6,application viewer 1.5 and xcode 4.1
  • WGSgamesWGSgames Posts: 22Member
    Hey gameARN, I have snow leopard with xcode 4.0.2. Everything else is the same as what you have. My problem was in the keychain. I must have accidentally deleted something that I shouldn't have. I had to back up all of my files and then completely wipe my computer clean and then install all of my programs again. I then followed everything exactly as it said on tshirtbooths video about certificates and provisioning profiles and it worked. I know its very frustrating but just stay focused and im sure youll get it figured out.
  • Fredrik BixoFredrik Bixo Posts: 239Member
    thank you WGSgames. I have now fixed it! that i did was that I:
    1.REVOKE MY DISTRIBUTION CERTIFICTE
    2.delete my provisioning profile
    3.deletet it from the keychain
    4. then i did tshirtbooths guide again :)
    link to my coming game (trailer):
This discussion has been closed.