Music isn't working

IsabelleKIsabelleK Member, Sous Chef Posts: 2,807
edited November -1 in Tech Support
Hello,
I tried to publish my game as beta build. Every time my music doesn't work on the device. In the Viewer it's ok. All sounds are working in beta build.

I used the same music in my previous game, and it worked fine. I tried music in mp3 and m4a formats.

Can anyone tell me what can be the cause of this?

Comments

  • HoneyTribeStudiosHoneyTribeStudios Member Posts: 1,792
    It might be the game center login bug:

    http://gamesalad.com/forums/topic.php?id=28829

    ----------
    image
    "Honey Tribe is not only a remarkably endearing little game, but it's also incredibly addictive." Pocket Gamer
    "...a touch above the rest in the endless running genre" 148apps.com
    Say hi on Twitter
    Like us on Facebook
    www.HoneyTribeStudios.com
  • IsabelleKIsabelleK Member, Sous Chef Posts: 2,807
    Thanks for your answer but I don't even have Pro :P So I don't use GC :)
  • HoneyTribeStudiosHoneyTribeStudios Member Posts: 1,792
    Try changing the device volume attribute to 1 in your scene and including the rule play music when device volume = 1

    Also you can try temporarily turning off any resume music rules
  • IsabelleKIsabelleK Member, Sous Chef Posts: 2,807
    HoneyTribeStudios said:
    Try changing the device volume attribute to 1 in your scene and including the rule play music when device volume = 1

    Also you can try temporarily turning off any resume music rules

    Thank you very much! That's the solution. There is a bug with GS, and it drops music volume to 0 in every scene :)
  • HoneyTribeStudiosHoneyTribeStudios Member Posts: 1,792
    You're welcome :)

    Yeah, I had the same thing and same situation.

    Just getting ready to upload a binary when.... hang on, the music isn't playing! Oh sh*t!

    Hopefully GS will change their testing procedures so these bugs get caught quicker!

    ----------
    image
    "Honey Tribe is not only a remarkably endearing little game, but it's also incredibly addictive." Pocket Gamer
    "...a touch above the rest in the endless running genre" 148apps.com
    Say hi on Twitter
    Like us on Facebook
    www.HoneyTribeStudios.com
  • DigiChainDigiChain Member, PRO Posts: 1,216
    Hi, I have the same issue - and have tried this fix.

    But the problem is - everytime I change scene the music restarts, rather than being a continuous seemless loop (as it was previously before the GS bug).

    Is there any way around this?
    Or is this the best solution until GS fix the problem properly?
  • DigiChainDigiChain Member, PRO Posts: 1,216
    UPDATE to my problem:

    The music plays when connected through the viewer - but once published these rules now knock the music off completely.

    What's going on! It really winds me up that GS keep releasing these bug updates!
  • micksolomicksolo Member Posts: 264
    I had a similar problem, the success music at end of level stopped playing, until I paused the game and unpaused it - then the music magically worked again.

    So at the start of my level I just put in a rule

    Pause Music
    Play Music (resume current track)

    and that fixed it.
  • DigiChainDigiChain Member, PRO Posts: 1,216
    This really caused me a big headache - but in the end the only thing that I could do to get it working again was to create a new actor and drop it in every scene.

    Within the actor I had a timer:
    Every 1 second>
    Change attribute - device - sound volume to 1
    Change attribute - device - music volume to 1

    This always restarts the music after you've minimised the game, and didn't ruin my music loop too.

    Hope that helps anyone also strugglling with this issue!
  • micksolomicksolo Member Posts: 264
    yeah its a bad bug, GS support told me its a known issue and they are fixing it for the next release which is good.

    Does your time slow down your game at all?
Sign In or Register to comment.