GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

save/load attributes not working :((((

LumpAppsLumpApps Posts: 2,868Member
edited November -1 in Tech Support
Hi,
I have worked with the save and load attributes with success in my previous game but now it will not work. I load the game in the viewer but no attributes are loaded (or saved, it is hard to tell)

In a scene where the score is displayed after each level it saves attributes for example game.highscore to key highscore

In the first scene it loads key: highscore to attribute game.highscore

But it doesn't load at all.

For testing I did:
I've made a new project with just 2 scenes. In scene one it loads an attribute and in scene two I made a scoresystem like tshirtboots example and a save attribute. Didn't work

I have tried a template from tshirt and added the save load attributes as in tshirtboots video. Didn't work.

I looked at my previous game how I did it (the same as in the new game) and tried that on the viewer: it worked...

So the only thing I can think of is when I make a project in 0.96 (or 0.971 since I updated today) doesn't work but my project made in an older version works.
I can't imagine this is right but it is the only conclusion I can draw now.

I am getting angry at this, it took me over a day now of testing and it has come to that point where I would like to throw my iPhone out of the window :(

Does anyone have any idea what I am doing wrong?
Perhaps someone can send me a test-file made in 0.96+ with a simpple load and save function to see if that works.

HEEEEEEELP!!!!!

Comments

  • LumpAppsLumpApps Posts: 2,868Member
    Ehm, I made a new test attribute and now it loads the value of this attribute to all load attributes, even with another key... ??
  • tenrdrmertenrdrmer Posts: 9,934Member, Sous Chef, Senior Sous-Chef
    I have just submitted a game Started with 0.9.6 and finished with 0.9.71 and the save load works perfectly.

    I would imagine its either how you are triggering the save. Or You need to double check your key. I did have a problem at one point But I found I have the key mistyped in a save.

    You want to make sure your game has chance to save. So don't place the save behaviors in a rule that is only valid for a split second. If it save is inside a timer make sure run to completion is checked.

    If its in a button make sure a change scene behavior is at the button since the engine reads the rule from the top down you might be triggering something that is happening before the save runs and essentially blocking it from happening.

    Theres lots of possibilities of why an easy way to check is in preview hit play so that it begins with you loading screen and then after the save should have happened Click the little reset icon in the preview window. That will simulate closing and opening an App and as long as you previewed the app from the load screen it will reset and load and saved attributes you have setup. If they are not loading right I would look at triggering the save differently.

    But first things first. Double check those keys.

    Good luck

    It's not my fault I never learned to take responsibility for anything. ;)

  • gyroscopegyroscope I am here.Posts: 6,577Member, Sous Chef, PRO
    That is really odd, Ludwig... sounding like a big bug.... I wonder if anyone else has the same problem. I'll see if I can find the time later to do a test; by the sound of it, it' sounds like I'll be able to duplicate the problem...

    Edit: just read tenrdrmer's good answer but I'll check it out all the same.

    ""You are in a maze of twisty passages, all alike." - Zork        temp domain http://spidergriffin.wix.com/alphaghostapps

  • LumpAppsLumpApps Posts: 2,868Member
    @tenrdrmer Ah, I didn't know the reset button worked that way. I thought attributes were not saved on the creator, that helps a lot testing.

    @Gyro, I appreciate any help. My head hurts, a painkiller would be nice too ;)
  • LumpAppsLumpApps Posts: 2,868Member
    Hm, I am only saving the test attribute now and none of the other scores.
    It still loads the test value to all attributes I load so my guess is there is a problem with the loading not the saving... testing testing!
  • LumpAppsLumpApps Posts: 2,868Member
    Yeah! I got it.
    I moved the load attribute from the first scene to the second (my 'main menu') and now it works.
    This must be a bug because I didn't change any of the load or save attributes only copied them from an actor in scene 1 to an actor in scene 2.

    The only thing I don't like but I can live with it that it now loads every attribute again when it comes to the main menu.

    Strange that I am the only one having this problem, not only in my new app but also in test projects, even when I follow tshirts save/load video.

    Thanks guys for your help. The reset button in the creator tip really saved me lots of time!
  • adnanadnan Posts: 46Member
    Hi,

    Guys I have the same problem, and I can't fix it. Anyone?
  • adnanadnan Posts: 46Member
    this is really ridiculous my game development has been stuck because of this problem, when will someone from gamesalad reply?
  • sideburns27sideburns27 Posts: 2Member
    First post on the forum...but same issue. On the viewer I can't get the save load to work. Programmed the same way.
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    sideburns27 said:
    First post on the forum...but same issue. On the viewer I can't get the save load to work. Programmed the same way.

    In the viewer the only way to test save and load is by exiting the game and reselecting threw the recent games tab in the viewer. Is that how your doing it? Because reloading the game each time save and load wont work
This discussion has been closed.