GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

iPhone publishing requires the iPhone SDK. Ensure that you have the latest iPhon

PauFontPauFont Posts: 4Member
ERROR MESSAGE: "iPhone publishing requires the iPhone SDK. Ensure that you have the latest iPhone SDK installed"

I've one app published in Appstore with Gamesalad one week ago only for iPad. Today I'm trying to do the same with very similar iPhone app and gives me this message. I have the latest SDK and latest Xcode. I've been reading some posts on forum about the same problem from months ago but I don't really find any solution from members. Thanks!

Comments

  • LeonardDeveloperLeonardDeveloper Posts: 4,630Member
    Download a newer version of Xcode! :),
    Happy to help! :)
  • PauFontPauFont Posts: 4Member
    I've installed one week ago 4.2 xcode version (Build 4C199). Is this the latest for Snow Leopard or not? I published one week ago but now don't work. Thanks
  • bajashbajash Posts: 215Member, PRO
    I have the latest for Snow Leopard and still problems
  • JPickardJPickard Posts: 477Member
    Please don't tell me we need Lion for gamesalad-iOS publishing. My Mac is too old to install it. :(
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    JPickard said:
    Please don't tell me we need Lion for gamesalad-iOS publishing. My Mac is too old to install it. :(

    nope i still havent upgraded to lion and dont plan on it for a little while. Ive spend to much money on licenses and software recently that have reported problems with lion still, so its not worth it for me to upgrade yet and risk something. And i have no issues publishing, published a couple tests last night and this morning.
  • PauFontPauFont Posts: 4Member
    I'm sure you don't need Lion to publish. I Published on Appstore one week ago with Snow Leopard, Xcode 4.2 and Gamesalad 0.9.85 beta, but today using the same tools returns me that message...this is my question. ;-)
  • PauFontPauFont Posts: 4Member
    I THINK FINALLY I'VE FOUND THE PROBLEM:

    Never, never, never move the SDK folder from default install. That's what I did and Gamesalad didn't find "the latest sdk version" because it wasn't in the right folder. Maybe Gamesalad should fix this or change the message "iPhone publishing requires the iPhone SDK. Ensure that you have the latest iPhone SDK installed" for "Gamesalad can't find your iphone SDK in your computer" and then a button to browse the folder, don't you think?
  • vicky1234vicky1234 Posts: 3Member
    i just got this problem , please how can I fix

    Thanks
  • JohnPapiomitisJohnPapiomitis Posts: 6,256Member
    @vicky

    Please dont bump old threads. You need to have the newest version of xcode downloaded.
This discussion has been closed.