GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Invalid Binary Problem (Please Help!)

NicholasSeahNicholasSeah Posts: 68Member
Hi all,

I got a problem with iTunes Connect, when I upload my game to Application Loader it passed, then in iTunes Connect my game app status changes to Upload Received, after a few minutes the status changes to Invalid Binary. What can I do to resolve this problem?

Comments

  • ccpccp Posts: 139Member
    That means that something was wrong with your upload. I would try re-uploading the file that gamesalad gives you. Also, make sure that it is zipped!
  • NicholasSeahNicholasSeah Posts: 68Member
    Hi CCP, thx for the reply, I uploaded the file that Gamesalad gave me many times but it's the same thing, the status changes from Upload Received to Invalid Binary
  • pixelknightspixelknights Posts: 68Member, PRO
    @NicholasSeah - Have you zipped the app before uploading?
  • NicholasSeahNicholasSeah Posts: 68Member
    Hi, yes I did
  • pixelknightspixelknights Posts: 68Member, PRO
    @NicholasSeah - I had the "invalid binary" error before, and the problem I had was that in my AppID in the iOS Provisioning Portal, I had iCloud enabled.. Once I Disabled this, renewed/download my distribution profile, publish the game in GameSalad again, zipped it up, and uploaded to itunesconnect everything was fine.

    So - check to make sure iCloud is DISABLED in your AppID on the iOS Provisioning Portal........... if that fails to work, someone else can join in and help.
  • NicholasSeahNicholasSeah Posts: 68Member
    Hi MikeZteel, Thanks for replying, I will try to resubmit again :D
  • NicholasSeahNicholasSeah Posts: 68Member
    Hi MikeZteel, IT WORKED!, Thank you very very much for your help! XD
  • pixelknightspixelknights Posts: 68Member, PRO
    @NicholasSeah - No Problem, I'm glad that I could help :)
  • LeonardDeveloperLeonardDeveloper Posts: 4,630Member
    Glad my advice worked for. You Nicholas!!
  • Neil7650Neil7650 Posts: 16Member
    thanks for your help MikeZteel!
This discussion has been closed.