Problem with jerky animation

brvidsbrvids Member Posts: 8
Hi, I'm new to gamesalad and having a problem with the animation playing correctly. I made an actor and added an animation behaviour to it. I then add my frames manually so I know they are in the right order. But when I preview the animation on my menu screen it's all jerky and only half of it is playing smoothly. It seems as if it is playing some of the frames out of order even though I know I added them in the correct order. Any help would be appreciated! Thanks

Answers

  • jonmulcahyjonmulcahy Member, Sous Chef, PRO Posts: 10,385
  • brvidsbrvids Member Posts: 8
    Post a screenshot of your animation rule
    Umm sorry I'll be honest I work on Windows a lot more than mac. Where and how exactly can I post a screen shot? I see no option for attachments here.
  • brvidsbrvids Member Posts: 8
    It seems pretty straight forward though. I don't see anything in the rule that suggests a problem. I have 30 frames in my animation and set it 15 fps. I have an image and tell it to loop through the animation. I also have restore actor image when done checked. The animation just plays all jerky even though I can play it in another program perfectly smooth.
  • jonmulcahyjonmulcahy Member, Sous Chef, PRO Posts: 10,385
    l
    Post a screenshot of your animation rule
    Umm sorry I'll be honest I work on Windows a lot more than mac. Where and how exactly can I post a screen shot? I see no option for attachments here.
    You have to use an online image host, just like in windows, gamesalad does not support hosting images.
  • RPRP Member Posts: 1,990
    How large is the animation image file per frame? Does animation take the entire screen space?

    Are certain parts of the animation jerky (repeats a frame or more incorrectly) or do you get stutter (pause-like slow playback) ?

    It is not uncommon that when you drag a series of animation frames into the animation behavior, that they do not fall into the correct play order. Go through the animation behavior thumbnails (double click on each one) to ensure that they are in the right play order.
  • MarkOnTheIronMarkOnTheIron Member Posts: 1,447
    The jerkiness (I'm not sure this word exist :) ) could also be due to the actual state of the GS preview. The last two updates brought it to a miserable state. Try it on the viewer or in an adhoc and see if the animation plays correctly.

  • brvidsbrvids Member Posts: 8
    I believe all my images are 128x128. Hey MarkOnTheIron I'm really new to Gamesalad, where is the viewer or better yet what do you mean adhoc? Like on my device itself? I really have a feeling this may just be software related like you say.
  • brvidsbrvids Member Posts: 8
    Hey guys I just started messing with it again and everything is working fine now! Go figure! I'm not sure what fixed it but I really appreciate all the quick responses! Thanks
  • rizwanashrizwanash Member Posts: 1
    Dear brvids Read @RP Comments for you .. Thats a Solution !
Sign In or Register to comment.