GameSalad

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Open URL to external links, from table?

Hi, I swear this was working previously, and definitely works on all iOS, but my external links have stopped working on Android, on my Kindle Fire HD.
Normal open URLs work, but I now have all my links in a table, to save time with multiple platforms. This works great with iOS devices, but it's looking like it totally doesn't work on Android.
Can anyone else confirm this please? If I can fully prove it to myself, then I'll confirm it back here myself!
Cheers
Wayne

Comments

  • SlowboySlowboy Posts: 329Member, PRO
    OK, so I think I can confirm that Open URL in Android can not have the URLs stored in a table. I'll put a bug report in now, but would also welcome any further comments here!
    Cheers
    Wayne
  • robert.mccarthyrobert.mccarthy Posts: 165Member
    Hi All,

    I have a table that holds web addresses (formatted like this http://www.google.com as text in the table)

    I have a button, which when pressed, is meant to use the URL behaviour and go to the website (pulling it from the table).

    Now when I run it in GS it works (and loads up the correct webpage).

    But when I run it on a device (this is any, iPhone or Android), it behaves as if no webpage has been passed.

    Has anyone else seen this issue, or even do you have a fix for it?

    Cheers,
  • robert.mccarthyrobert.mccarthy Posts: 165Member
    So having a 'list' of links anywhere (either in tables or global attribute), you cannot pull them into the URL behaviour?
  • SocksSocks London, UK.Posts: 12,822Member
    I know this might be obvious, but you can of course list your web addresses as separate rules.

    If the number selected is 1 open URL address 1
    If the number selected is 2 open URL address 2
    If the number selected is 3 open URL address 3
    If the number selected is 4 open URL address 4

    . . . etc
  • SlowboySlowboy Posts: 329Member, PRO
    Hi, I have had urls in tables working perfectly on iOS, but it wouldn't work on Android, so I (annoyingly) had to make separate rules for those.
    But now, I have noticed that in my recently released app, no links work at all?! :[ Everything still works fine in the preview, all links from tables work, but not in the released version.
    So, not sure how to solve this, just bumming around on the forums to see if anyone else has this trouble, this is the first thread I have found along these lines...
    To clarify, Mr. McCarthy - In my experience links in tables DID work fine in preview and in released apps, but NOT on Android, but now, links in tables DON'T work in the release apps, but DO work in the GS Preview. How tedious!
    Oh, and Socks, the reason I am eager to use tables rather than separate rules is to switch easily between platforms. If I want to release on iPad them Android, all I do is change a 'Device' attribute from 1 to 2, and the rule picks out the relevant link from the table. It was supposedly going to save me a ton of time, but annoyances like this seem to be negating any time saved so far!!
  • SlowboySlowboy Posts: 329Member, PRO
    Hmm, Open URLs from table is now busted in my released apps on Mac and iOS, but still work fine in the Previewer. Anyone been using tables for URLs? Anyone had trouble lately?
    Ta
    Wayne
  • PixelMetalPixelMetal Posts: 283Member
    Report it as a bug (because it is).
  • tatiangtatiang Posts: 11,490Member, Sous Chef, PRO, Senior Sous-Chef
    [Threads merged]

    New to GameSalad? (FAQs)   |   Tutorials   |   Templates   |   Greenleaf Games   |   Educator & Certified GameSalad User

  • SlowboySlowboy Posts: 329Member, PRO
    Bugged.
  • kanuvaskanuvas Posts: 21Member
    Glad I found a bug :) (this is our PRO account hence different name)

    Cheers Guys

    Rob
This discussion has been closed.